poj3069贪心

Saruman's Army
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7709 Accepted: 3941

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

分析:

最左边的点必须覆盖,不妨先从最左边不在覆盖范围内的第一个点找起,找距离它最远的点,然后标记;

再根据标记的点找到左起不在覆盖范围内的第一个点;

以此类推,最后修改程序满足边界条件;

<span style="font-size:14px;">/*
* Filename:    code.cpp
* Created:     2016-08-03
* Author:        yunlong Wang  
*[mail:17744454343@163.com]
* Desciption:  Desciption
*/
#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <stack>
#include <queue>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <vector>
#include <bitset>
#include <list>
#include <sstream>
#include <set>
#include <functional>
using namespace std;

#define INT_MAX 1 << 30
#define MAX 100
typedef long long ll;
int r;
int n;
int x[1001];

void solve()
{
    int i = 0;//获取不在范围内的左起第一个点
    int ans = 0;
    while(i <= n-1)
    {
        int e = i+1;
        while((x[i]+r >= x[e]) && (e <= n-1)) e++;//获取需标记点的右边第一个点
        int p = e-1;//需标记的点
        while((x[p]+r >= x[e]) && (e <= n-1)) e++;//获取不在范围内的左起第一个点
        ans++;
        i = e;
    }
    printf("%d",ans);
}

int main()
{
    while (scanf("%d%d",&r,&n)!=EOF)
    {
        if(r == -1 && n == -1) break;
        for (int i = 0; i < n; i += 1)
        {
            scanf("%d",&x[i]);
        }
        sort(x,x+n);
        solve();
        printf("\n");
    }
    return 0;
}</span>


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值