poj3253Fence Repair解法之贪心

Fence Repair
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 39794 Accepted: 12979

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer  N, the number of planks 
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make  N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

每次选取集合内最小的两个合并,重新放到集合中去;合并过程中计算开销。

其实这一题比较好的解法是用huffman树;此处用贪心

<span style="font-size:14px;">/*
* Filename:    code.cpp
* Created:     2016-08-04
* Author:        yunlong Wang  
*[mail:17744454343@163.com]
* Desciption:  Desciption
*/
#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <stack>
#include <queue>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <vector>
#include <bitset>
#include <list>
#include <sstream>
#include <set>
#include <functional>
using namespace std;

#define INT_MAX 1 << 30
#define MAX 100
typedef long long ll;
int n;
int a[20001];


void solve()
{
    sort(a,a+n);//可以改善程序,貌似没卵用
    ll ans = 0;
    while (n > 1)
    {
        //每次获取最小的两个整数,复杂度为O(n)
        int min1 = 0,min2 = 1;
        if (a[min1] > a[min2]) swap(min1,min2);
        for (int i = 2; i < n; i += 1)
        {
            if (a[i] < a[min1]) 
            { 
                min2 = min1; 
                min1 = i;
            }
            else if (a[i] < a[min2])
            {
                min2 = i;
            } 
        }
        //将新的结果放到原集合中
        int t = a[min1]+a[min2];
        ans += t;
        
        if (min1 == n-1) 
            swap(min1,min2);
        a[min1] = t;    //新结果放到min1处
        a[min2] = a[n-1];//截取尾部接到min2处,注意尾部可以为自身,不能为min1
        n--;
    }
    printf("%lld\n",ans);
}

int main(int argc, char const* argv[])
{
    scanf("%d",&n);
    for (int i = 0; i < n; i += 1)
    {
        scanf("%d",&a[i]);
    }
    solve();
    return 0;
}</span>


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值