PAT A 1096. Consecutive Factors (20)

题目

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<231).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format "factor[1]*factor[2]*...*factor[k]", where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7


求一个数的各个因数分解中,最长的连续的一串因数。

如果按暴力方法进行质因数分解,再组合,将是o(2^n),显然是不可能的。


实际只需要尝试从2开始,从3开始...的各个连续的分解。保留暂时的最佳结果即可。


代码:

#include <iostream>
#include <vector>
using namespace std;

int main()
{
	long long n;
	cin>>n;

	vector<int> ans(1,n),tpv;	//结果(n本身是必然存在的一个最短结果),临时结果
	int tempi;
	for(long long i=2;i*i<=n;i++)	//分解的起始位置
	{
		tpv.clear();
		tempi=n;
		for(long long j=i;j<=tempi;j++)	//连续分解,不成立则退出
		{
			if(tempi%j==0)
			{
				tpv.push_back(j);
				tempi/=j;
			}
			else
				break;
		}
		if(tpv.size()>ans.size())	//判断是否比暂存的最优更好
			ans=tpv;
		else if(tpv.size()==ans.size()&&tpv[0]<ans[0])
			ans=tpv;
	}

	cout<<ans.size()<<endl;	//输出结果
	cout<<ans[0];
	for(int i=1;i<ans.size();i++)
		cout<<"*"<<ans[i];

	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值