poj 1681 画家问题

Description

There is a square wall which is made of n*n small square bricks. Some bricks are white while some bricks are yellow. Bob is a painter and he wants to paint all the bricks yellow. But there is something wrong with Bob's brush. Once he uses this brush to paint brick (i, j), the bricks at (i, j), (i-1, j), (i+1, j), (i, j-1) and (i, j+1) all change their color. Your task is to find the minimum number of bricks Bob should paint in order to make all the bricks yellow. 

Input

The first line contains a single integer t (1 <= t <= 20) that indicates the number of test cases. Then follow the t cases. Each test case begins with a line contains an integer n (1 <= n <= 15), representing the size of wall. The next n lines represent the original wall. Each line contains n characters. The j-th character of the i-th line figures out the color of brick at position (i, j). We use a 'w' to express a white brick while a 'y' to express a yellow brick.

Output

For each case, output a line contains the minimum number of bricks Bob should paint. If Bob can't paint all the bricks yellow, print 'inf'.

Sample Input

2
3
yyy
yyy
yyy
5
wwwww
wwwww
wwwww
wwwww
wwwww

Sample Output

0
15
解题思路:
一开始以为变黄了就不能变白,结果后来发现可以,那就和1222差不多了。思路都是一样的,枚举第一行,然后推算剩下几行,最后验证最后一行是否全黄就可以了。

代码:
#include <stdio.h>
#include <stdlib.h>
int main()
{


    int success,i,j,t,n,step;
    char ch;
    scanf("%d",&t);


    while(t--){
        scanf("%d",&n);


        char wall[n+1][n+2];
        int paint[n+1][n+2];


        for(i=1;i<n+1;i++){
            while((ch=getchar())!='\n');
            for(j=1;j<n+1;j++)
                scanf("%c",&wall[i][j]);
        }


        for(i=0;i<n+1;i++)
            for(j=0;j<n+2;j++)
                paint[i][j]=0;


        while(paint[1][n+1]!=1){
            step=0;success=1;


            for(i=2;i<n+1;i++)
                for(j=0;j<n+2;j++)
                    paint[i][j]=0;


            for(i=1;i<n;i++)
                for(j=1;j<n+1;j++){
                    if(wall[i][j]=='w'&&(paint[i-1][j]+paint[i][j+1]+paint[i][j-1]+paint[i][j])%2==0){
                    paint[i+1][j]=1;
                    }
                    if(wall[i][j]=='y'&&(paint[i-1][j]+paint[i][j+1]+paint[i][j-1]+paint[i][j])%2==1){
                    paint[i+1][j]=1;
                    }
                }


            for(j=1;j<n+1;j++){
                if(wall[n][j]=='w'&&(paint[n-1][j]+paint[n][j-1]+paint[n][j]+paint[n][j+1])%2==0){
                    success=0;
                    break;
                }
                if(wall[n][j]=='y'&&(paint[n-1][j]+paint[n][j-1]+paint[n][j]+paint[n][j+1])%2==1){
                    success=0;
                    break;
                }
            }


            if(success)
                break;


            i=1;
            paint[1][1]++;
            while(paint[1][i]>1){
                paint[1][i]=0;
                i++;
                paint[1][i]++;
            }
        }


        for(i=1;i<n+1;i++)
            for(j=1;j<n+1;j++)
                if(paint[i][j]==1)
                step++;


        if(paint[1][n+1]==1)
            printf("inf\n");
        else
            printf("%d\n",step);
    }
    return 0;
}

用malloc不知道为什么内存超限,改用变长数组就过了。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值