微分方程_______Rower Bo( HDU 5761 2016多校第三场)

Problem Description
There is a river on the Cartesian coordinate system,the river is flowing along the x-axis direction.

Rower Bo is placed at  (0,a)  at first.He wants to get to origin  (0,0)  by boat.Boat speed relative to water is  v1 ,and the speed of the water flow is  v2 .He will adjust the direction of  v1  to origin all the time.

Your task is to calculate how much time he will use to get to origin.Your answer should be rounded to four decimal places.

If he can't arrive origin anyway,print"Infinity"(without quotation marks).
 

Input
There are several test cases. (no more than 1000)

For each test case,there is only one line containing three integers  a,v1,v2 .

0a100 0v1,v2,100 a,v1,v2  are integers
 

Output
For each test case,print a string or a real number.

If the absolute error between your answer and the standard answer is no more than  104 , your solution will be accepted.
 

Sample Input
  
  
2 3 3 2 4 3
 

Sample Output
  
  
Infinity 1.1428571429
 


题意:

最开始在(0,a)点有一艘船,水流方向朝向X轴正方向,速度为V1,船的速度为V2,船在行驶过程中速度方向一直朝向原点。问多久才能到达原点?


分析:

因为速度是变方向,所以要用积分来做,最开始我对距离积分没算出来,后来看了题解才知道要分别对X轴方向和斜轴方向积分。

,我们换一个思路,不分解v1分解v2,在斜方向上对速度积分,得到这样一个式子: 

T0(v1cosθv2) dt=a

    可以看到在这样一个式子里,我们只有 cosθ ,于是我们把这个式子和前面在x轴方向上积分的式子 
T0(v2cosθv1) dt=0

    联立,消去 cosθ 就行了。 
    最终得到

T=v1av21v22



代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>

using namespace std;

int a,v1,v2;

int main()
{
    while(scanf("%d%d%d",&a,&v1,&v2)!=EOF)
    {
        if (a==0)  { printf("0\n"); continue ; }
        if (v1<=v2)
        {
            printf("Infinity\n");
            continue ;
        }
        double t= 1.0*a*v1/(v1*v1-v2*v2);
        printf("%lf\n",t);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值