zoj 3706 Break Standard Weight

Break Standard Weight

Time Limit: 2 Seconds      Memory Limit: 65536 KB

The balance was the first mass measuring instrument invented. In its traditional form, it consists of a pivoted horizontal lever of equal length arms, called the beam, with a weighing pan, also called scale, suspended from each arm (which is the origin of the originally plural term "scales" for a weighing instrument). The unknown mass is placed in one pan, and standard masses are added to this or the other pan until the beam is as close to equilibrium as possible. The standard weights used with balances are usually labeled in mass units, which are positive integers.

With some standard weights, we can measure several special masses object exactly, whose weight are also positive integers in mass units. For example, with two standard weights 1 and 5, we can measure the object with mass 1, 4, 5 or 6 exactly.

In the beginning of this problem, there are 2 standard weights, which masses are x and y. You have to choose a standard weight to break it into 2 parts, whose weights are also positive integers in mass units. We assume that there is no mass lost. For example, the origin standard weights are 4 and 9, if you break the second one into 4 and 5, you could measure 7 special masses, which are 1, 3, 4, 5, 8, 9, 13. While if you break the first one into 1 and 3, you could measure 13 special masses, which are 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13! Your task is to find out the maximum number of possible special masses.

Input

There are multiple test cases. The first line of input is an integer T < 500 indicating the number of test cases. Each test case contains 2 integers x and y. 2 ≤ x, y ≤ 100

Output

For each test case, output the maximum number of possible special masses.

Sample Input
2
4 9
10 10
Sample Output
13
9

Author: YU, Zhi

Contest: The 10th Zhejiang Provincial Collegiate Programming Contest

题目大意。给你两个砝码。你可以把其中一个砝码拆分成两个。问你用拆分后的砝码最多可以组合出多少重量


#include<stdio.h>

int c;//记录组合数
int s[20];
int abs(int x)//求绝对值
{
    if(x<0)
        x=-x;
    return x;
}
void add(int *s,int x)//把可组合出的重量存入s数组。
{
    int i;
    if(x==0)//0不满足条件
        return ;
    for(i=0; i<c; i++)
        if(s[i]==x)//如果可组合出的重量已存在则直接返回
            return;
    s[i]=x;//没存在加入解集合
    c++;
}
int solve(int a,int b)//拆分b找出最多组合数
{
    int cc,bb,i,ma=-1;

    for(i=1; i<=b/2; i++)//枚举b的拆分方法
    {
        c=0;
        cc=b-i;
        bb=i;//只可能有一下13中组合方式
        add(s,a);
        add(s,bb);
        add(s,cc);
        add(s,a+bb);
        add(s,a+cc);
        add(s,bb+cc);
        add(s,a+bb+cc);
        add(s,abs(a-bb));
        add(s,abs(a-cc));
        add(s,abs(bb-cc));
        add(s,abs(a+bb-cc));
        add(s,abs(a+cc-bb));
        add(s,abs(bb+cc-a));
        if(c>ma)//ma记录解最多个数
            ma=c;
    }
    return ma;
}
int main()
{
    int t,a,b,m1,m2;

    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&a,&b);
        m1=solve(a,b);
        m2=solve(b,a);
        printf("%d\n",m1>m2?m1:m2);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值