CentOS下装oracle 12c(命令行模式安装)

原创 2015年07月08日 12:00:26

 

实验环境:



1:安装oracle所需软件包 

Oracle 12c所需的rpm包如下:

binutils-2.20.51.0.2-5.11.el6 (x86_64)
compat-libcap1-1.10-1 (x86_64)
compat-libstdc++-33-3.2.3-69.el6 (x86_64)
compat-libstdc++-33-3.2.3-69.el6 (i686)
gcc-4.4.4-13.el6 (x86_64)
gcc-c++-4.4.4-13.el6 (x86_64)
glibc-2.12-1.7.el6 (i686)
glibc-2.12-1.7.el6 (x86_64)
glibc-devel-2.12-1.7.el6 (x86_64)
glibc-devel-2.12-1.7.el6 (i686)
ksh
libgcc-4.4.4-13.el6 (i686)
libgcc-4.4.4-13.el6 (x86_64)
libstdc++-4.4.4-13.el6 (x86_64)
libstdc++-4.4.4-13.el6 (i686)
libstdc++-devel-4.4.4-13.el6 (x86_64)
libstdc++-devel-4.4.4-13.el6 (i686)
libaio-0.3.107-10.el6 (x86_64)
libaio-0.3.107-10.el6 (i686)
libaio-devel-0.3.107-10.el6 (x86_64)
libaio-devel-0.3.107-10.el6 (i686)
libXext-1.1 (x86_64)
libXext-1.1 (i686)
libXtst-1.0.99.2 (x86_64)
libXtst-1.0.99.2 (i686)
libX11-1.3 (x86_64)
libX11-1.3 (i686)
libXau-1.0.5 (x86_64)
libXau-1.0.5 (i686)
libxcb-1.5 (x86_64)
libxcb-1.5 (i686)
libXi-1.3 (x86_64)
libXi-1.3 (i686)
make-3.81-19.el6
sysstat-9.0.4-11.el6 (x86_64)

 

[root@ser6-51 mongodb]# yum install binutils compat-libcap1 compat-libstdc++-33 gcc gcc-c++ glibc glibc-devel ksh libgcc libstdc++ libstdc++-devel libaio libaio-devel libXext libXtst libX11 libXau libxcb libXi make sysstat

Loaded plugins: fastestmirror, security
Determining fastest mirrors
 * base: mirrors.163.com
 * extras: mirrors.aliyun.com
 * updates: mirrors.163.com
base                                                                                                                                                                              | 3.7 kB     00:00     
extras                                                                                                                                                                            | 3.4 kB     00:00     
updates                                                                                                                                                                           | 3.4 kB     00:00     
updates/primary_db                                                                                                                                                                | 3.9 MB     00:04     
Setting up Install Process
Package gcc-4.4.7-11.el6.x86_64 already installed and latest version
Package gcc-c++-4.4.7-11.el6.x86_64 already installed and latest version
Package libgcc-4.4.7-11.el6.x86_64 already installed and latest version
Package libstdc++-4.4.7-11.el6.x86_64 already installed and latest version
Package libstdc++-devel-4.4.7-11.el6.x86_64 already installed and latest version
Package libaio-0.3.107-10.el6.x86_64 already installed and latest version
Package libXau-1.0.6-4.el6.x86_64 already installed and latest version
Package 1:make-3.81-20.el6.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package binutils.x86_64 0:2.20.51.0.2-5.36.el6 will be updated
---> Package binutils.x86_64 0:2.20.51.0.2-5.42.el6 will be an update
---> Package compat-libcap1.x86_64 0:1.10-1 will be installed
---> Package compat-libstdc++-33.x86_64 0:3.2.3-69.el6 will be installed
---> Package glibc.x86_64 0:2.12-1.132.el6 will be updated
--> Processing Dependency: glibc = 2.12-1.132.el6 for package: glibc-headers-2.12-1.132.el6.x86_64
--> Processing Dependency: glibc = 2.12-1.132.el6 for package: glibc-common-2.12-1.132.el6.x86_64
---> Package glibc.x86_64 0:2.12-1.149.el6_6.9 will be an update
---> Package glibc-devel.x86_64 0:2.12-1.132.el6 will be updated
---> Package glibc-devel.x86_64 0:2.12-1.149.el6_6.9 will be an update
---> Package ksh.x86_64 0:20120801-21.el6_6.3 will be installed
---> Package libX11.x86_64 0:1.5.0-4.el6 will be updated
---> Package libX11.x86_64 0:1.6.0-2.2.el6 will be an update
--> Processing Dependency: libX11-common = 1.6.0-2.2.el6 for package: libX11-1.6.0-2.2.el6.x86_64
---> Package libXext.x86_64 0:1.3.1-2.el6 will be updated
---> Package libXext.x86_64 0:1.3.2-2.1.el6 will be an update
---> Package libXi.x86_64 0:1.6.1-3.el6 will be updated
---> Package libXi.x86_64 0:1.7.2-2.2.el6 will be an update
---> Package libXtst.x86_64 0:1.2.1-2.el6 will be updated
---> Package libXtst.x86_64 0:1.2.2-2.1.el6 will be an update
---> Package libaio-devel.x86_64 0:0.3.107-10.el6 will be installed
---> Package libxcb.x86_64 0:1.8.1-1.el6 will be updated
---> Package libxcb.x86_64 0:1.9.1-2.el6 will be an update
---> Package sysstat.x86_64 0:9.0.4-22.el6 will be updated
---> Package sysstat.x86_64 0:9.0.4-27.el6 will be an update
--> Running transaction check
---> Package glibc-common.x86_64 0:2.12-1.132.el6 will be updated
---> Package glibc-common.x86_64 0:2.12-1.149.el6_6.9 will be an update
---> Package glibc-headers.x86_64 0:2.12-1.132.el6 will be updated
---> Package glibc-headers.x86_64 0:2.12-1.149.el6_6.9 will be an update
---> Package libX11-common.noarch 0:1.5.0-4.el6 will be updated
---> Package libX11-common.noarch 0:1.6.0-2.2.el6 will be an update
--> Finished Dependency Resolution
 
Dependencies Resolved
 
=========================================================================================================================================================================================================
 Package                                               Arch                                     Version                                                  Repository                                 Size
=========================================================================================================================================================================================================
Installing:
 compat-libcap1                                        x86_64                                   1.10-1                                                   base                                       17 k
 compat-libstdc++-33                                   x86_64                                   3.2.3-69.el6                                             base                                      183 k
 ksh                                                   x86_64                                   20120801-21.el6_6.3                                      updates                                   758 k
 libaio-devel                                          x86_64                                   0.3.107-10.el6                                           base                                       13 k
Updating:
 binutils                                              x86_64                                   2.20.51.0.2-5.42.el6                                     base                                      2.8 M
 glibc                                                 x86_64                                   2.12-1.149.el6_6.9                                       updates                                   3.8 M
 glibc-devel                                           x86_64                                   2.12-1.149.el6_6.9                                       updates                                   984 k
 libX11                                                x86_64                                   1.6.0-2.2.el6                                            base                                      586 k
 libXext                                               x86_64                                   1.3.2-2.1.el6                                            base                                       35 k
 libXi                                                 x86_64                                   1.7.2-2.2.el6                                            base                                       37 k
 libXtst                                               x86_64                                   1.2.2-2.1.el6                                            base                                       19 k
 libxcb                                                x86_64                                   1.9.1-2.el6                                              base                                      110 k
 sysstat                                               x86_64                                   9.0.4-27.el6                                             base                                      233 k
Updating for dependencies:
 glibc-common                                          x86_64                                   2.12-1.149.el6_6.9                                       updates                                    14 M
 glibc-headers                                         x86_64                                   2.12-1.149.el6_6.9                                       updates                                   612 k
 libX11-common                                         noarch                                   1.6.0-2.2.el6                                            base                                      192 k
 
Transaction Summary
=========================================================================================================================================================================================================
Install       4 Package(s)
Upgrade      12 Package(s)
 
Total download size: 24 M
Is this ok [y/N]: y
Downloading Packages:
(1/16): binutils-2.20.51.0.2-5.42.el6.x86_64.rpm                                                                                                                                  | 2.8 MB     00:02     
(2/16): compat-libcap1-1.10-1.x86_64.rpm                                                                                                                                          |  17 kB     00:00     
(3/16): compat-libstdc++-33-3.2.3-69.el6.x86_64.rpm                                                                                                                               | 183 kB     00:00     
(4/16): glibc-2.12-1.149.el6_6.9.x86_64.rpm                                                                                                                                       | 3.8 MB     00:05     
(5/16): glibc-common-2.12-1.149.el6_6.9.x86_64.rpm                                                                                                                                |  14 MB     00:13     
(6/16): glibc-devel-2.12-1.149.el6_6.9.x86_64.rpm                                                                                                                                 | 984 kB     00:02     
(7/16): glibc-headers-2.12-1.149.el6_6.9.x86_64.rpm                                                                                                                               | 612 kB     00:01     
(8/16): ksh-20120801-21.el6_6.3.x86_64.rpm                                                                                                                                        | 758 kB     00:01     
(9/16): libX11-1.6.0-2.2.el6.x86_64.rpm                                                                                                                                           | 586 kB     00:01     
(10/16): libX11-common-1.6.0-2.2.el6.noarch.rpm                                                                                                                                   | 192 kB     00:00     
(11/16): libXext-1.3.2-2.1.el6.x86_64.rpm                                                                                                                                         |  35 kB     00:00     
(12/16): libXi-1.7.2-2.2.el6.x86_64.rpm                                                                                                                                           |  37 kB     00:00     
(13/16): libXtst-1.2.2-2.1.el6.x86_64.rpm                                                                                                                                         |  19 kB     00:00     
(14/16): libaio-devel-0.3.107-10.el6.x86_64.rpm                                                                                                                                   |  13 kB     00:00     
(15/16): libxcb-1.9.1-2.el6.x86_64.rpm                                                                                                                                            | 110 kB     00:00     
(16/16): sysstat-9.0.4-27.el6.x86_64.rpm                                                                                                                                          | 233 kB     00:00     
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                                    712 kB/s |  24 MB     00:35     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : glibc-common-2.12-1.149.el6_6.9.x86_64                                                                                                                                               1/28 
  Updating   : glibc-2.12-1.149.el6_6.9.x86_64                                                                                                                                                      2/28 
  Updating   : glibc-headers-2.12-1.149.el6_6.9.x86_64                                                                                                                                              3/28 
  Updating   : libxcb-1.9.1-2.el6.x86_64                                                                                                                                                            4/28 
  Updating   : libX11-common-1.6.0-2.2.el6.noarch                                                                                                                                                   5/28 
  Updating   : libX11-1.6.0-2.2.el6.x86_64                                                                                                                                                          6/28 
  Updating   : libXext-1.3.2-2.1.el6.x86_64                                                                                                                                                         7/28 
  Updating   : libXi-1.7.2-2.2.el6.x86_64                                                                                                                                                           8/28 
  Updating   : libXtst-1.2.2-2.1.el6.x86_64                                                                                                                                                         9/28 
  Updating   : glibc-devel-2.12-1.149.el6_6.9.x86_64                                                                                                                                               10/28 
  Installing : compat-libcap1-1.10-1.x86_64                                                                                                                                                        11/28 
  Updating   : sysstat-9.0.4-27.el6.x86_64                                                                                                                                                         12/28 
  Installing : ksh-20120801-21.el6_6.3.x86_64                                                                                                                                                      13/28 
  Installing : compat-libstdc++-33-3.2.3-69.el6.x86_64                                                                                                                                             14/28 
  Updating   : binutils-2.20.51.0.2-5.42.el6.x86_64                                                                                                                                                15/28 
  Installing : libaio-devel-0.3.107-10.el6.x86_64                                                                                                                                                  16/28 
  Cleanup    : glibc-devel-2.12-1.132.el6.x86_64                                                                                                                                                   17/28 
  Cleanup    : libXtst-1.2.1-2.el6.x86_64                                                                                                                                                          18/28 
  Cleanup    : glibc-headers-2.12-1.132.el6.x86_64                                                                                                                                                 19/28 
  Cleanup    : libXi-1.6.1-3.el6.x86_64                                                                                                                                                            20/28 
  Cleanup    : libXext-1.3.1-2.el6.x86_64                                                                                                                                                          21/28 
  Cleanup    : libX11-1.5.0-4.el6.x86_64                                                                                                                                                           22/28 
  Cleanup    : libxcb-1.8.1-1.el6.x86_64                                                                                                                                                           23/28 
  Cleanup    : binutils-2.20.51.0.2-5.36.el6.x86_64                                                                                                                                                24/28 
  Cleanup    : sysstat-9.0.4-22.el6.x86_64                                                                                                                                                         25/28 
  Cleanup    : libX11-common-1.5.0-4.el6.noarch                                                                                                                                                    26/28 
  Cleanup    : glibc-common-2.12-1.132.el6.x86_64                                                                                                                                                  27/28 
  Cleanup    : glibc-2.12-1.132.el6.x86_64                                                                                                                                                         28/28 
  Verifying  : glibc-devel-2.12-1.149.el6_6.9.x86_64                                                                                                                                                1/28 
  Verifying  : libaio-devel-0.3.107-10.el6.x86_64                                                                                                                                                   2/28 
  Verifying  : libX11-1.6.0-2.2.el6.x86_64                                                                                                                                                          3/28 
  Verifying  : compat-libcap1-1.10-1.x86_64                                                                                                                                                         4/28 
  Verifying  : libXext-1.3.2-2.1.el6.x86_64                                                                                                                                                         5/28 
  Verifying  : glibc-2.12-1.149.el6_6.9.x86_64                                                                                                                                                      6/28 
  Verifying  : sysstat-9.0.4-27.el6.x86_64                                                                                                                                                          7/28 
  Verifying  : ksh-20120801-21.el6_6.3.x86_64                                                                                                                                                       8/28 
  Verifying  : compat-libstdc++-33-3.2.3-69.el6.x86_64                                                                                                                                              9/28 
  Verifying  : glibc-headers-2.12-1.149.el6_6.9.x86_64                                                                                                                                             10/28 
  Verifying  : binutils-2.20.51.0.2-5.42.el6.x86_64                                                                                                                                                11/28 
  Verifying  : libXtst-1.2.2-2.1.el6.x86_64                                                                                                                                                        12/28 
  Verifying  : libXi-1.7.2-2.2.el6.x86_64                                                                                                                                                          13/28 
  Verifying  : glibc-common-2.12-1.149.el6_6.9.x86_64                                                                                                                                              14/28 
  Verifying  : libxcb-1.9.1-2.el6.x86_64                                                                                                                                                           15/28 
  Verifying  : libX11-common-1.6.0-2.2.el6.noarch                                                                                                                                                  16/28 
  Verifying  : glibc-2.12-1.132.el6.x86_64                                                                                                                                                         17/28 
  Verifying  : glibc-devel-2.12-1.132.el6.x86_64                                                                                                                                                   18/28 
  Verifying  : glibc-headers-2.12-1.132.el6.x86_64                                                                                                                                                 19/28 
  Verifying  : glibc-common-2.12-1.132.el6.x86_64                                                                                                                                                  20/28 
  Verifying  : binutils-2.20.51.0.2-5.36.el6.x86_64                                                                                                                                                21/28 
  Verifying  : libXi-1.6.1-3.el6.x86_64                                                                                                                                                            22/28 
  Verifying  : libX11-common-1.5.0-4.el6.noarch                                                                                                                                                    23/28 
  Verifying  : sysstat-9.0.4-22.el6.x86_64                                                                                                                                                         24/28 
  Verifying  : libxcb-1.8.1-1.el6.x86_64                                                                                                                                                           25/28 
  Verifying  : libXtst-1.2.1-2.el6.x86_64                                                                                                                                                          26/28 
  Verifying  : libX11-1.5.0-4.el6.x86_64                                                                                                                                                           27/28 
  Verifying  : libXext-1.3.1-2.el6.x86_64                                                                                                                                                          28/28 
 
Installed:
  compat-libcap1.x86_64 0:1.10-1               compat-libstdc++-33.x86_64 0:3.2.3-69.el6               ksh.x86_64 0:20120801-21.el6_6.3               libaio-devel.x86_64 0:0.3.107-10.el6              
 
Updated:
  binutils.x86_64 0:2.20.51.0.2-5.42.el6      glibc.x86_64 0:2.12-1.149.el6_6.9      glibc-devel.x86_64 0:2.12-1.149.el6_6.9      libX11.x86_64 0:1.6.0-2.2.el6      libXext.x86_64 0:1.3.2-2.1.el6     
  libXi.x86_64 0:1.7.2-2.2.el6                libXtst.x86_64 0:1.2.2-2.1.el6         libxcb.x86_64 0:1.9.1-2.el6                  sysstat.x86_64 0:9.0.4-27.el6     
 
Dependency Updated:
  glibc-common.x86_64 0:2.12-1.149.el6_6.9                           glibc-headers.x86_64 0:2.12-1.149.el6_6.9                           libX11-common.noarch 0:1.6.0-2.2.el6                          
 
Complete!


验证 Oracle 所需要的系统依赖程序包是否完整。

 

 

[root@ser6-51 mongodb]# rpm -qa binutils compat-libcap1 compat-libstdc++-33 gcc gcc-c++ glibc glibc-devel ksh libgcc libstdc++ libstdc++-devel libaio libaio-devel libXext libXtst libX11 libXau libxcb libXi make sysstat

libgcc-4.4.7-11.el6.x86_64
libstdc++-4.4.7-11.el6.x86_64
gcc-c++-4.4.7-11.el6.x86_64
glibc-2.12-1.149.el6_6.9.x86_64
libX11-1.6.0-2.2.el6.x86_64
glibc-devel-2.12-1.149.el6_6.9.x86_64
compat-libstdc++-33-3.2.3-69.el6.x86_64
make-3.81-20.el6.x86_64
libaio-0.3.107-10.el6.x86_64
libXau-1.0.6-4.el6.x86_64
libstdc++-devel-4.4.7-11.el6.x86_64
libXext-1.3.2-2.1.el6.x86_64
libXtst-1.2.2-2.1.el6.x86_64
compat-libcap1-1.10-1.x86_64
ksh-20120801-21.el6_6.3.x86_64
binutils-2.20.51.0.2-5.42.el6.x86_64
gcc-4.4.7-11.el6.x86_64
libxcb-1.9.1-2.el6.x86_64
libXi-1.7.2-2.2.el6.x86_64
sysstat-9.0.4-27.el6.x86_64
libaio-devel-0.3.107-10.el6.x86_64

 

2对OS进行配置


2.1 创建相关用户和用户组

groupadd oinstall

groupadd oper

groupadd dba

useradd -g oinstall -G dba,oper oracle

 

2.2 修改oracle用户的密码

passwd oracle

 

2.3 修改系统参数

vi /etc/sysctl.conf

添加:

 

fs.aio-max-nr = 1048576
fs.file-max = 6815744
kernel.shmall = 2097152
kernel.shmmax = 536870912
kernel.shmmni = 4096
kernel.sem = 250 32000 100 128
net.ipv4.ip_local_port_range = 9000 65500
net.core.rmem_default = 262144
net.core.rmem_max = 4194304
net.core.wmem_default = 262144
net.core.wmem_max = 1048586

 

运行sysctl -p应用以上参数

/sbin/sysctl -p 

 

2.4 修改用户Limits

vi /etc/security/limits.conf

新增如下内容:

oracle soft nofile 65536

oracle hard nofile 65536

oracle soft nproc 16384

oracle hard nproc 16384

oracle stack nproc 10240

oracle stack nproc 10240

 

2.5 创建相关目录

mkdir -p /u01/app/oracle/product/12c/db_1  

mkdir –p /u01/app/oracle/oradata

mkdir –p /u01/app/oracle/flash_recovery_area

mkdir -p /u01/app/oracle/archlog

chown -R oracle:oinstall /u01

2.6 配置环境变量

su - oracle 

vi .bash_profile

添加:

# Oracle Settings
COLUMNS=132; export COLUMNS
LINES=47; export LINES
EDITOR=vi; export EDITOR
 
TMP=/tmp; export TMP
TMPDIR=$TMP; export TMPDIR
ORACLE_BASE=/u01/app/oracle; export ORACLE_BASE
ORACLE_HOME=$ORACLE_BASE/product/12c/db_1; export ORACLE_HOME
ORACLE_SID=orcl; export ORACLE_SID
SHLIB_PATH=$LD_LIBRARY_PATH;export SHLIB_PATH
NLS_LANG=American_America.zhs16gbk;export NLS_LANG
ORA_NLS10=$ORACLE_HOME/nls/data;export ORA_NLS10
TNS_ADMIN=$ORACLE_HOME/network/admin;export TNS_ADMIN
ORACLE_TERM=xterm; export ORACLE_TERM
PATH=/usr/sbin:$PATH; export PATH
PATH=$ORACLE_HOME/bin:$PATH; export PATH
LD_LIBRARY_PATH=$ORACLE_HOME/lib:/lib:/usr/lib; export LD_LIBRARY_PATH
CLASSPATH=$ORACLE_HOME/jre:$ORACLE_HOME/jlib:$ORACLE_HOME/rdbms/jlib; export CLASSPATH
alias glance=/opt/perf/bin/glance:x
alias gohome='cd /u01/app/oracle/product/10.2.0'
alias cdb='cd /u01/app/oracle/admin/orcl/bdump'
alias cdu='cd /u01/app/oracle/admin/orcl/udump'


--里面的内容可以根据实际情况进行改动,如可以改动ORACLE_SID.

修改完用:source .bash_profile生效。

 

2.7修改/etc/hosts 

[oracle@ser6-51 ~]$ cat /etc/hosts

127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4

::1         localhost localhost.localdomain localhost6 localhost6.localdomain6

 

[oracle@ser6-51 ~]$ hostname

ser6-51

 

 

把127.0.0.1那一行改为:127.0.0.1   ser6-51

 

2.8修改操作系统发行版本

由于 oracle 还没有推出支持 CentOS 的安装包,所以需要修改发行版本,以便通过 oracle 的安装检查

vi /etc/redhat-release 

把CentOS release 6.5 (Final) 注释掉,前面加上一行redhat-4,当oracle安装完成后,再修改回来。

如:

redhat-4

#CentOS release 6.5 (Final)

2.9 关闭SELINUX


vi /etc/selinux/config

将SELINUX那一行改成:

SELINUX=disabled

3:安装


3.1 解压安装包

[root@ser6-51 download]# ls -ltr

-rw-r--r-- 1 root root 1014530602 Jul  6 15:07 linuxamd64_12102_database_2of2.zip

-rw-r--r-- 1 root root 1673544724 Jul  6 15:12 linuxamd64_12102_database_1of2.zip

 

[root@ser6-51 download]# unzip linuxamd64_12102_database_1of2.zip 

[root@ser6-51 download]# unzip linuxamd64_12102_database_2of2.zip 

 

[root@ser6-51 download]# ls -ltr

drwxr-xr-x 7 root root       4096 Jul  7  2014 database

-rw-r--r-- 1 root root 1014530602 Jul  6 15:07 linuxamd64_12102_database_2of2.zip

-rw-r--r-- 1 root root 1673544724 Jul  6 15:12 linuxamd64_12102_database_1of2.zip

 

3.2 安装oracle软件


3.2.1 新建静默安装的应答文件

su - oracle

 

vi 12102db_install.rsp

添加:

######################################################################
## Copyright(c) Oracle Corporation 1998,2013. All rights reserved.                                  ##
##                                                                     ##
## Specify values for the variables listed below to customize                                        ##
## your installation.                                                             ##
##                                                                     ##
## Each variable is associated with a comment. The comment                                ##
## can help to populate the variables with the appropriate                                       ##
## values.                                                                 ##
##                                                                     ##
## IMPORTANT NOTE: This file contains plain text passwords and                               ##
## should be secured to have read permission only by oracle user                                  ##
## or db administrator who owns this installation.                                            ##
##                                                                     ##
######################################################################
 
#-------------------------------------------------------------------------------
# Do not change the following system generated value.
#-------------------------------------------------------------------------------
oracle.install.responseFileVersion=/oracle/install/rspfmt_dbinstall_response_schema_v12.1.0
 
#-------------------------------------------------------------------------------
# Specify the installation option.
# It can be one of the following:
#   - INSTALL_DB_SWONLY
#   - INSTALL_DB_AND_CONFIG
#   - UPGRADE_DB
#------------------------------------------------------------------------------
oracle.install.option=INSTALL_DB_SWONLY
 
#-------------------------------------------------------------------------------
# Specify the hostname of the system as set during the install. It can be used
# to force the installation to use an alternative hostname rather than using the
# first hostname found on the system. (e.g., for systems with multiple hostnames
# and network interfaces)
#-------------------------------------------------------------------------------
ORACLE_HOSTNAME=ser6-51
 
#-------------------------------------------------------------------------------
# Specify the Unix group to be set for the inventory directory. 
#-------------------------------------------------------------------------------
UNIX_GROUP_NAME=oinstall
 
#-------------------------------------------------------------------------------
# Specify the location which holds the inventory files.
# This is an optional parameter if installing on
# Windows based Operating System.
#-------------------------------------------------------------------------------
INVENTORY_LOCATION=/u01/app/oraInventory
 
#-------------------------------------------------------------------------------
# Specify the languages in which the components will be installed.            
#
# en   : English                  ja   : Japanese                  
# fr   : French                   ko   : Korean                   
# ar   : Arabic                   es   : Latin American Spanish   
# bn   : Bengali                  lv   : Latvian                  
# pt_BR: Brazilian Portuguese     lt   : Lithuanian               
# bg   : Bulgarian                ms   : Malay                    
# fr_CA: Canadian French          es_MX: Mexican Spanish          
# ca   : Catalan                  no   : Norwegian                
# hr   : Croatian                 pl   : Polish                   
# cs   : Czech                    pt   : Portuguese               
# da   : Danish                   ro   : Romanian                 
# nl   : Dutch                    ru   : Russian                  
# ar_EG: Egyptian                 zh_CN: Simplified Chinese       
# en_GB: English (Great Britain)  sk   : Slovak                   
# et   : Estonian                 sl   : Slovenian                
# fi   : Finnish                  es_ES: Spanish                   
# de   : German                   sv   : Swedish                  
# el   : Greek                    th   : Thai                     
# iw   : Hebrew                   zh_TW: Traditional Chinese      
# hu   : Hungarian                tr   : Turkish                  
# is   : Icelandic                uk   : Ukrainian                
# in   : Indonesian               vi   : Vietnamese               
# it   : Italian                                                  
#
# all_langs   : All languages
#
# Specify value as the following to select any of the languages.
# Example : SELECTED_LANGUAGES=en,fr,ja
#
# Specify value as the following to select all the languages.
# Example : SELECTED_LANGUAGES=all_langs 
#-------------------------------------------------------------------------------
SELECTED_LANGUAGES=en
 
#-------------------------------------------------------------------------------
# Specify the complete path of the Oracle Home.
#-------------------------------------------------------------------------------
ORACLE_HOME=/u01/app/oracle/product/12c/db_1
 
#-------------------------------------------------------------------------------
# Specify the complete path of the Oracle Base.
#-------------------------------------------------------------------------------
ORACLE_BASE=/u01/app/oracle
 
#-------------------------------------------------------------------------------
# Specify the installation edition of the component.                    
#                                                             
# The value should contain only one of these choices.       
#   - EE     : Enterprise Edition                               
#   - SE     : Standard Edition                                 
#   - SEONE  : Standard Edition One
#   - PE     : Personal Edition (WINDOWS ONLY)
#-------------------------------------------------------------------------------
oracle.install.db.InstallEdition=EE
 
#################################################################################
#                                                                                  #
# PRIVILEGED OPERATING SYSTEM GROUPS                                                #
# ------------------------------------------                                                                         #
# Provide values for the OS groups to which OSDBA and OSOPER privileges                                        #
# needs to be granted. If the install is being performed as a member of the                                           #
# group "dba", then that will be used unless specified otherwise below.                                            #
#                                                                                  #
# The value to be specified for OSDBA and OSOPER group is only for UNIX based                             #
# Operating System.                                                                      #
#                                                                                  #
###############################################################################
 
#------------------------------------------------------------------------------
# The DBA_GROUP is the OS group which is to be granted OSDBA privileges.
#-------------------------------------------------------------------------------
oracle.install.db.DBA_GROUP=dba
 
#------------------------------------------------------------------------------
# The OPER_GROUP is the OS group which is to be granted OSOPER privileges.
# The value to be specified for OSOPER group is optional.
#------------------------------------------------------------------------------
oracle.install.db.OPER_GROUP=oper
 
#------------------------------------------------------------------------------
# The BACKUPDBA_GROUP is the OS group which is to be granted OSBACKUPDBA privileges.
#------------------------------------------------------------------------------
oracle.install.db.BACKUPDBA_GROUP=dba
 
#------------------------------------------------------------------------------
# The DGDBA_GROUP is the OS group which is to be granted OSDGDBA privileges.
#------------------------------------------------------------------------------
oracle.install.db.DGDBA_GROUP=dba
 
#------------------------------------------------------------------------------
# The KMDBA_GROUP is the OS group which is to be granted OSKMDBA privileges.
#------------------------------------------------------------------------------
oracle.install.db.KMDBA_GROUP=dba
 
################################################################################
#                                                                              #
#                        Database Configuration Options                               #
#                                                                              #
################################################################################
 
#-------------------------------------------------------------------------------
# Specify the type of database to create.
# It can be one of the following:
#   - GENERAL_PURPOSE/TRANSACTION_PROCESSING                      
#   - DATA_WAREHOUSE                               
#-------------------------------------------------------------------------------
oracle.install.db.config.starterdb.type=
 
#-------------------------------------------------------------------------------
# Specify the Starter Database Global Database Name.
#-------------------------------------------------------------------------------
oracle.install.db.config.starterdb.globalDBName=
 
#-------------------------------------------------------------------------------
# Specify the Starter Database SID.
#-------------------------------------------------------------------------------
oracle.install.db.config.starterdb.SID=
 
#-------------------------------------------------------------------------------
# Specify whether the database should be configured as a Container database.
#-------------------------------------------------------------------------------
oracle.install.db.ConfigureAsContainerDB=
 
#-------------------------------------------------------------------------------
# Specify the  Pluggable Database name for the pluggable database in Container Database.
#-------------------------------------------------------------------------------
oracle.install.db.config.PDBName=
 
#-------------------------------------------------------------------------------
# Specify the Starter Database character set.
#                                               
#  One of the following
#  AL32UTF8, WE8ISO8859P15, WE8MSWIN1252, EE8ISO8859P2,
#  EE8MSWIN1250, NE8ISO8859P10, NEE8ISO8859P4, BLT8MSWIN1257,
#  BLT8ISO8859P13, CL8ISO8859P5, CL8MSWIN1251, AR8ISO8859P6,
#  AR8MSWIN1256, EL8ISO8859P7, EL8MSWIN1253, IW8ISO8859P8,
#  IW8MSWIN1255, JA16EUC, JA16EUCTILDE, JA16SJIS, JA16SJISTILDE,
#  KO16MSWIN949, ZHS16GBK, TH8TISASCII, ZHT32EUC, ZHT16MSWIN950,
#  ZHT16HKSCS, WE8ISO8859P9, TR8MSWIN1254, VN8MSWIN1258
#-------------------------------------------------------------------------------
oracle.install.db.config.starterdb.characterSet=
 
#------------------------------------------------------------------------------
# This variable should be set to true if Automatic Memory Management
# in Database is desired.
# If Automatic Memory Management is not desired, and memory allocation
# is to be done manually, then set it to false.
#------------------------------------------------------------------------------
oracle.install.db.config.starterdb.memoryOption=
 
#-------------------------------------------------------------------------------
# Specify the total memory allocation for the database. Value(in MB) should be
# at least 256 MB, and should not exceed the total physical memory available
# on the system.
# Example: oracle.install.db.config.starterdb.memoryLimit=512
#-------------------------------------------------------------------------------
oracle.install.db.config.starterdb.memoryLimit=
 
#################################################################################
#                                                                                  #
# Passwords can be supplied for the following four schemas in the                                                       #
# starter database:                                                                                                                                      #
#   SYS                                                                            #
#   SYSTEM                                                                        #
#   DBSNMP (used by Enterprise Manager)                                                   #
#                                                                                  #
# Same password can be used for all accounts (not recommended)                                                     #
# or different passwords for each account can be provided (recommended)                                     #
#                                                                                  #
#################################################################################
 
#------------------------------------------------------------------------------
# This variable holds the password that is to be used for all schemas in the
# starter database.
#-------------------------------------------------------------------------------
oracle.install.db.config.starterdb.password.ALL=oracle
 
#-------------------------------------------------------------------------------
# Specify the SYS password for the starter database.
#-------------------------------------------------------------------------------
oracle.install.db.config.starterdb.password.SYS=
 
#-------------------------------------------------------------------------------
# Specify the SYSTEM password for the starter database.
#-------------------------------------------------------------------------------
oracle.install.db.config.starterdb.password.SYSTEM=
 
#-------------------------------------------------------------------------------
# Specify the DBSNMP password for the starter database.
#-------------------------------------------------------------------------------
oracle.install.db.config.starterdb.password.DBSNMP=
 
#-------------------------------------------------------------------------------
# Specify the PDBADMIN password required for creation of Pluggable Database in the Container Database.
#-------------------------------------------------------------------------------
oracle.install.db.config.starterdb.password.PDBADMIN=
#------------------------------------------------------------------------------
# Specify whether user doesn't want to configure Security Updates.
# The value for this variable should be true if you don't want to configure
# Security Updates, false otherwise.
#
# The value can be either true or false. If left blank it will be assumed
# to be false.
#
# Example    : DECLINE_SECURITY_UPDATES=false
#------------------------------------------------------------------------------
DECLINE_SECURITY_UPDATES=true
#------------------------------------------------------------------------------
# Specify the auto-updates option. It can be one of the following:
#   - MYORACLESUPPORT_DOWNLOAD
#   - OFFLINE_UPDATES
#   - SKIP_UPDATES
#------------------------------------------------------------------------------
oracle.installer.autoupdates.option=SKIP_UPDATES


 

3.2.2 静默安装软件

[root@ser6-51 install]# su - oracle

[oracle@ser6-51 ~]$ cd /download/database/

[oracle@ser6-51 database]$ ./runInstaller  -silent -responseFile /home/oracle/12102db_install.rsp

 

  

/*

假如安装过程中报错了,已经在$ORACLE_HOME/u01/app/oraInventory下生成了很多文件目录。想再次安装的话,需要先删除这些文件:

[oracle@ser6-52 app]$ pwd

/u01/app

[oracle@ser6-52 app]$ rm -rf /u01/app/oraInventory

 

cd $ORACLE_HOME/

rm  -rf *

*/

执行两个脚本:

[root@ser6-51 ~]# sh /u01/app/oraInventory/orainstRoot.sh 

Changing permissions of /u01/app/oraInventory.

Adding read,write permissions for group.

Removing read,write,execute permissions for world.

 

Changing groupname of /u01/app/oraInventory to oinstall.

The execution of the script is complete.

 

root@ser6-51 ~]# sh /u01/app/oracle/product/12c/db_1/root.sh 

Check /u01/app/oracle/product/12c/db_1/install/root_ser6-51_2015-07-06_19-00-11.log for the output of root script

 

 

3.3 建库

 

 

3.3.1 建响应文件

v i /home/oracle/dbca.rsp

添加:

[GENERAL]
RESPONSEFILE_VERSION = "12.1.2.0"
OPERATION_TYPE = "createDatabase"
[CREATEDATABASE]
GDBNAME = "orcl"
SID = "orcl"
TEMPLATENAME = "New_Database.dbt"
SYSPASSWORD = "orcl"
SYSTEMPASSWORD = "orcl"
SYSMANPASSWORD = "orcl"
DBSNMPPASSWORD = "orcl"
DATAFILEDESTINATION ="/u01/app/oracle/oradata"
STORAGETYPE=FS
CHARACTERSET = "ZHS16GBK"
DATABASETYPE = "MULTIPURPOSE"
AUTOMATICMEMORYMANAGEMENT = "FALSE"


 

3.3.2 执行命令

dbca -silent -responseFile /home/oracle/dbca.rsp

 

Creating and starting Oracle instance
1% complete
4% complete
Creating database files
5% complete
9% complete
Creating data dictionary views
10% complete
13% complete
14% complete
15% complete
16% complete
17% complete
18% complete
21% complete
22% complete
23% complete
24% complete
Adding Oracle JVM
30% complete
37% complete
44% complete
46% complete
Adding Oracle Text
47% complete
48% complete
50% complete
51% complete
Adding Oracle Multimedia
52% complete
65% complete
Adding Oracle OLAP
66% complete
67% complete
68% complete
69% complete
Adding Oracle Spatial
70% complete
78% complete
Adding Oracle Application Express
83% complete
87% complete
Completing Database Creation
89% complete
90% complete
91% complete
95% complete
100% complete


 

 

[oracle@ser6-51 dbs]$ export ORACLE_SID=orcl

[oracle@ser6-51 dbs]$ sqlplus / as sysdba

 

SQL*Plus: Release 12.1.0.2.0 Production on Wed Jul 8 09:29:16 2015

 

Copyright (c) 1982, 2014, Oracle.  All rights reserved.

 

 

Connected to:

Oracle Database 12c Enterprise Edition Release 12.1.0.2.0 - 64bit Production

With the Partitioning, OLAP, Advanced Analytics and Real Application Testing options

 

SQL> select status from v$instance;

 

STATUS

------------

OPEN

 

 

 

3.4配监听

 

3.4.1 建响应文件

vi 12102_netca.rsp

添加:

[GENERAL]
RESPONSEFILE_VERSION="12.1"
CREATE_TYPE="CUSTOM"
 
#-------------------------------------------------------------------------------
# Name       : SHOW_GUI
# Datatype   : Boolean
# Description: This variable controls appearance/suppression of the NetCA GUI,
# Pre-req    : N/A
# Default    : TRUE
# Note:
# This must be set to false in order to run NetCA in silent mode.
# This is a substitute of "/silent" flag in the NetCA command line.
# The command line flag has precedence over the one in this response file.
# This feature is present since 10.1.0.3.
#-------------------------------------------------------------------------------
#SHOW_GUI=false
 
#-------------------------------------------------------------------------------
# Name       : LOG_FILE
# Datatype   : String
# Description: If present, NetCA will log output to this file in addition to the
#              standard out.
# Pre-req    : N/A
# Default    : NONE
# Note:
#      This is a substitute of "/log" in the NetCA command line.
# The command line argument has precedence over the one in this response file.
# This feature is present since 10.1.0.3.
#-------------------------------------------------------------------------------
#LOG_FILE=""/oracle12cHome/network/tools/log/netca.log""
 
[oracle.net.ca]
#INSTALLED_COMPONENTS;StringList;list of installed components
# The possible values for installed components are:
# "net8","server","client","aso", "cman", "javavm"
INSTALLED_COMPONENTS={"server","net8","javavm"}
 
#INSTALL_TYPE;String;type of install
# The possible values for install type are:
# "typical","minimal" or "custom"
INSTALL_TYPE=""typical""
 
#LISTENER_NUMBER;Number;Number of Listeners
# A typical install sets one listener
LISTENER_NUMBER=1
 
#LISTENER_NAMES;StringList;list of listener names
# The values for listener are:
# "LISTENER","LISTENER1","LISTENER2","LISTENER3", ...
# A typical install sets only "LISTENER"
LISTENER_NAMES="LISTENER"
 
#LISTENER_PROTOCOLS;StringList;list of listener addresses (protocols and parameters separated by semicolons)
# The possible values for listener protocols are:
# "TCP;1521","TCPS;2484","NMP;ORAPIPE","IPC;IPCKEY","VI;1521"
# A typical install sets only "TCP;1521"
LISTENER_PROTOCOLS="TCP;1521"
 
#LISTENER_START;String;name of the listener to start, in double quotes
LISTENER_START=""LISTENER""
 
#NAMING_METHODS;StringList;list of naming methods
# The possible values for naming methods are:
# LDAP, TNSNAMES, ONAMES, HOSTNAME, NOVELL, NIS, DCE
# A typical install sets only: "TNSNAMES","ONAMES","HOSTNAMES"
# or "LDAP","TNSNAMES","ONAMES","HOSTNAMES" for LDAP
NAMING_METHODS={"TNSNAMES","ONAMES","HOSTNAME"}
 
#NOVELL_NAMECONTEXT;String;Novell Directory Service name context, in double quotes
# A typical install does not use this variable.
#NOVELL_NAMECONTEXT = ""NAMCONTEXT""
 
#SUN_METAMAP;String; SUN meta map, in double quotes
# A typical install does not use this variable.
#SUN_METAMAP = ""MAP""
 
#DCE_CELLNAME;String;DCE cell name, in double quotes
# A typical install does not use this variable.
#DCE_CELLNAME = ""CELL""
 
#NSN_NUMBER;Number;Number of NetService Names
# A typical install sets one net service name
NSN_NUMBER=1
 
#NSN_NAMES;StringList;list of Net Service names
# A typical install sets net service name to "EXTPROC_CONNECTION_DATA"
NSN_NAMES="EXTPROC_CONNECTION_DATA"
 
#NSN_SERVICE;StringList;Oracle12c database's service name
# A typical install sets Oracle12c database's service name to "PLSExtProc"
NSN_SERVICE="PLSExtProc"


 

3.4.2 执行命令

[oracle@ser6-51 ~]$ netca -silent -responseFile /home/oracle/12102_netca.rsp

 

Parsing command line arguments:

    Parameter "silent" = true

    Parameter "responsefile" = /home/oracle/12102_netca.rsp

Done parsing command line arguments.

Oracle Net Services Configuration:

Profile configuration complete.

Oracle Net Listener Startup:

    Running Listener Control: 

      /u01/app/oracle/product/12c/db_1/bin/lsnrctl start LISTENER

    Listener Control complete.

    Listener started successfully.

Listener configuration complete.

Oracle Net Services configuration successful. The exit code is 0

 

 

4:设置开机启动

4.1 修改dbstart文件

假如执行/u01/app/oracle/product/12c/db_1/bin/dbstart报错:

ORACLE_HOME_LISTNER is not SET, unable to auto-start Oracle Net Listener
Usage: /u01/app/oracle/oracle/product/10.2.0/db_1/bin/dbstart ORACLE_HOME

修改dbstart文件,将ORACLE_HOME_LISTNER=$1

修改为ORACLE_HOME_LISTNER=$ORACLE_HOME

 

4.2修改/etc/oratab

添加:

orcl:/u01/app/oracle/product/12c/db_1:Y

4.3修改/etc/rc.d/rc.local

添加一行:

su oracle -lc /u01/app/oracle/product/12c/db_1/bin/dbstart

--说明:/u01/app/oracle/product/12c/dbhome_1为oracle的安装目录,要根据实际情况进行修改。

 

reboot试验下看是否能开机自动启动。

 

5:开1521端口

如果防火墙开启了的话,要开1521端口,允许远程访问。

vi /etc/sysconfig/iptables

直接在配置文件里已有的-A INPUT那些命令下面

添加一行:

-A INPUT -m state --state NEW -m tcp -p tcp --dport 1521-j ACCEPT

重启防火墙

[root@ser6-52 mongodb]# /etc/init.d/iptables restart

iptables: Setting chains to policy ACCEPT: filter          [  OK  ]

iptables: Flushing firewall rules:                         [  OK  ]

iptables: Unloading modules:                               [  OK  ]

iptables: Applying firewall rules:                         [  OK  ]

 

6:后续配置

#把操作系统版本改回原来的配置

[root@pc ~]# vi /etc/redhat-release

Red Hat Enterprise Linux Server release 5.8 (Tikanga)

修改后:

#redhat-4

CentOS release 6.5 (Final)

 

对应步骤2.8


--本篇文章主要参考文章:http://www.woqutech.com/?p=894

--静默方式建库参考这篇文章



版权声明:本文为博主原创文章,未经博主允许不得转载。 举报

相关文章推荐

LINUX7(CentOS7)上安装Oracle 12C

原创作品,出自 “深蓝的blog” 博客,欢迎转载,转载时请务必注明以下出处,否则追究版权法律责任。 深蓝的blog:   实验环境:Oracle VM VirtualBox 4.2.12 操作系统:...

Centos 7 Oracle 12C 超详细安装

[1] Install Desktop Environment, refer to here. [2] Install required packages. [root@dlp ~...

精选:深入理解 Docker 内部原理及网络配置

网络绝对是任何系统的核心,对于容器而言也是如此。Docker 作为目前最火的轻量级容器技术,有很多令人称道的功能,如 Docker 的镜像管理。然而,Docker的网络一直以来都比较薄弱,所以我们有必要深入了解Docker的网络知识,以满足更高的网络需求。

centos7 oracle 12c 安装问题记录

centos7 oracle 12c 安装问题记录 CentOS 机器: Exception in thread "main" java.lang.NoClassDefFoundError...

Oracle12c for CentOs6.5安装

1.      检查软硬件要求 a.      物理内存 [root@ora12c ~]# grep MemTotal/proc/meminfo MemTotal: ...

Centos6.5安装Oracle12c安装笔记

声明:本篇博文转自madking的  http://blog.csdn.net/madking/article/details/39493025 结合自己安装遇到的坑给予说明  说明: ...

centos7安装oracle12c

本文 基本参考了下面这篇文章 http://blog.csdn.net/gq5251/article/details/42004035 但是改正了一些错误 操作系统:CentOS Linux r...

Linux 安装 Oracle 11g——准备工作

一、完成Linux的最小化安装 Desktop(包含图形化界面):一般默认选择,方便安装mini:无图形化 二、系统环境管理

连接被拒绝 因为没有授权此用户账户进行远程登录

背景:有时想远程连接某服务器进行操作,但是远程登陆时,却报错: 解决办法:在服务器上进行设置,允许用户登录 步骤: 1:用允许登录的用户,远程连接服务器(在这里用v-liyh登录) 点...

Linux下安装xwindow图形界面

执行命令 yum -y groupinstall Desktop  yum -y groupinstall "X Window System" 然后执行"startx"命令,正常情况下,可以启动图...

用xstart远程连接linux图形用户界面

有时工作中,我们需要用到linux图形用户界面环境进行一些操作(比如装oracle数据库等等),这时就需要用xstart远程连接linux图形用户界面,这样我们就不用特意跑到机房操作服务器了。前提是要...
返回顶部
收藏助手
不良信息举报
您举报文章:深度学习:神经网络中的前向传播和反向传播算法推导
举报原因:
原因补充:

(最多只允许输入30个字)