关闭

RHEL 6.4(i386)编译安装cmake 2.8.12

3357人阅读 评论(0) 收藏 举报
分类:
将RHEL的yum软件源更换为CentOS的软件源之后,其中的cmake版本太低,为2.6.4版本,编译较新的软件时会提示cmake版本太低,所以有必要编译安装最新版的cmake。

1. 更换yum软件源

2. 安装gcc 4.8.1

3. 获取cmake 2.8.12源码包
cd /root/Downloads/

4. 解压cmake 2.8.12源码包

5. 编译并安装
cd cmake-2.8.12.1
./bootstrap
gmake
gmake install

6. 检查安装是否成功
cmake --version
若安装成功,则会显示以下信息:
cmake version 2.8.12.1

异常情况:
如果在bootstrap时报错,可能原因是依赖的程序包未安装。解决方法:安装依赖的程序包后,将cmake-2.8.12.1/目录下的CMakeCache.txt删掉,再重新从bootstrap开始。

环境描述:
系统:RHEL 6.4 i386 (Desktop)
虚拟机:VMware Workstation 9.0.0 build-812388
登录用户:root
0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:233251次
    • 积分:2322
    • 等级:
    • 排名:第16704名
    • 原创:39篇
    • 转载:9篇
    • 译文:3篇
    • 评论:42条
    最新评论