POJ 3984-----E - 广搜记录路径 基础

                                         
E - 广搜记录路径 基础
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

定义一个二维数组: 
int maze[5][5] = {

 0, 1, 0, 0, 0,

 0, 1, 0, 1, 0,

 0, 0, 0, 0, 0,

 0, 1, 1, 1, 0,

 0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

//@author:  yzj   Date:2015/07/26
//sourse :  http://acm.hust.edu.cn/vjudge/contest/view.action?cid=82603#problem/C
//meaning:  马踏棋盘,求马从一个点到另一个点所走的最短路径
#include <iostream>
#include <cstdio>
#include <queue>

using namespace std;
const int  MAXN  = 300+5;
int n, sx, sy, ex, ey;
char ch_sy, ch_ey;
bool vis[MAXN][MAXN];
int step[MAXN][MAXN];
int dx[8] = {-1,1,2, 2,  1, -1, -2, -2};
int dy[8] = {2, 2,1, -1, -2, -2, -1, 1};

typedef pair<int, int> P;

int bfs()
{
    queue<P> que;
    while(!que.empty())
    {
        que.pop();
    }
    for(int i = 0; i < MAXN; i++)
    {
        for(int j = 0; j < MAXN; j++)
        {
            vis[i][j] = false;
            step[i][j] = 0;
        }
    }
    que.push(P(sx, sy));
    vis[sx][sy] = true;
    step[sy][sy] = 0;
    while(! que.empty())
    {
        P p = que.front();
        if(p.first == ex && p.second == ey) return step[p.first][p.second];
        que.pop();
        for(int i = 0; i < 8; i++)
        {
            int nx = p.first + dx[i], ny = p.second + dy[i];
            if(0<=nx&&nx<n&&0<=ny&&ny<n&&!vis[nx][ny])
            {
                que.push(P(nx, ny));
                vis[nx][ny] = true;
                step[nx][ny] = step[p.first][p.second] + 1;
            }
        }
    }
}

int main()
{
    //freopen("f:/yzj/cppCode/input.txt", "r", stdin);
    int cas;
    scanf("%d", &cas);
    while(cas--)
    {
        scanf("%d", &n);
        scanf("%d %d %d %d", &sx, &sy, &ex, &ey);
        printf("%d\n", bfs());
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值