HDU 1016 Prime Ring Problem(DFS)

Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1. 


 

Input

n (0 < n < 20). 
 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. 

You are to write a program that completes above process. 

Print a blank line after each case. 
 

Sample Input

    
    
6 8
 

Sample Output

    
    
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 



代码如下:

#include<stdio.h>
#include<string.h>
#include<math.h>
/*一维数组(judge[ ])标记某个数
是否已用,num数组用来储存1到n个数,
其下标与其值相等,即num[1]=1,num[n]=n*/
int j,n,judge[21],num[21];
//判断i是否是素数
int prime(int i)
{
    int k=2;
    while(k<=sqrt(i))
        if(i%k++==0) return 0;
    return 1;
}
//深度搜索,找到两数之和是素数的数
void DFS(int num[],int n)
{
    int i;
    /*判定n个数是否用完并且最后一个数和
    第一个是的和是否是素数,如果都符合,
    则这n个数可以构成素数环,便可输出num[].*/

    if(j==n&&prime(1+num[n-1])==1)
    {
        /*注意输出格式(最后一个数后面
        没有空格),还可用如下方式输出:
        printf("%d",num[0]);
        for(i=1;i<n;i++)
            printf(" %d",num[i]);
        printf("\n");*/
        for(i=0;i<n-1;i++)
            printf("%d ",num[i]);
        printf("%d\n",num[n-1]);
    }
    else
    {
        for(i=1;i<n;i++)
        {
            if(judge[i]&&prime(num[j-1]+i+1))
            {
                num[j++]=i+1;
                judge[i]=0;
                DFS(num,n);
                --j;//当前边未找到,回溯到上一边重新查找
                judge[i]=1;
            }
        }
    }
}
int main()
{
    int i,n,sum=1;
    while(scanf("%d",&n)!=EOF)
    {
        memset(judge,1,sizeof(judge));
        judge[0]=0;
        j=0;
        printf("Case %d:\n",sum++);
        num[j++]=1;
        DFS(num,n);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值