如何在ubuntu提高jdk版本

转载 2016年08月31日 07:48:17

The easy way

The easiest way to install the JDK 7 is to do it with the Web Up8 Oracle Java OOS. However, it is believed that this PPA is sometimes out of date. Also note the dangers of using a PPA.

This installs JDK 7 (which includes Java JDK, JRE and the Java browser plugin):

sudo apt-get install python-software-properties
sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java7-installer
//or if you want JDK 8:
sudo apt-get install oracle-java8-installer
/* these commands install Oracle JDK7/8 and set them as default VMs automatically:*/
sudo apt-get install oracle-java7-set-default
sudo apt-get install oracle-java8-set-default
参考链接
http://askubuntu.com/questions/56104/how-can-i-install-sun-oracles-proprietary-java-jdk-6-7-8-or-jre

相关文章推荐

Ubuntu14.04配置JDK任何版本

我们以JDK1.8.0_121为例一、 首先下载JDK压缩包到桌面,或者从你自己的笔记本传JDK到虚拟机中,此部分不在叙述。下载地址: http://www.oracle.com/technetw...

Android实战技巧之八:Ubuntu下切换JDK版本

Android L之后推荐使用JDK7编译程序,这是自然发展规律,就像是4年前编译Android 1.6需要使用JDK5一样。 多版本JDK是可以共存的,只需要使用update-alternative...

Linux Ubuntu下安装多个版本JDK

转载自:http://atell.iteye.com/blog/1169556 我的ubuntu系统中,既安装了openjdk,又安装了jdk5,jdk6.其中,openjdk是使用debian自动...

Ubuntu make 及多版本JDK安装与切换

环境:Ubuntu 14.04.3 LTS 一 安装android开发环境 ubuntu 15 提供了 ubuntu make,使用它可以很方便的安装各种开发环境, 使用它安装Android 开...

ubuntu新版本下找不到sun-java5-jdk的解决办法

默认ubuntu9.04以上的版本源里已经没有sun-java5-jdk的源,使用如下方法安装:一:备份/etc/apt/sources.list,然后将里面的内容替换为deb http://ubun...

ubuntu 安装升级java jdk 版本

http://blog.csdn.net/shenshendeai/article/details/54133270 http://www.cnblogs.com/a2211009/p/...

Ubuntu14.04下Tomcat8.0和jdk1.8版本安装

最近需要在linux下用到tomcat的环境,目前使用的linux服务器的是ubuntu14.04的x64版本的。 所以需要在这里安装tomcat8.0和对应的jdk1.8。 tomcat和jdk的下...

Ubuntu 10.04环境下载&编译Android源代码及JDK版本切换

前言本文叙述了如何从零开始搭建基于Google官方Android 2.1-r2源码的开发环境,包括如何下载源代码、编译源代码,以及在模拟器中运行编译生成的镜像。文中开发机是基于Ubuntu 10.04...

ubuntu安装多版本JDK

我目前的环境是ubuntu 13.10 64bits,系统默认安装openJDK 1.7,但是编译android source code要求JDK版本为1.6 1. 下载JDK 到java官网http...
  • w_xue
  • w_xue
  • 2014-09-04 10:36
  • 1920

Ubuntu 下环境到搭建:安装JDK1.7,安装eclipse,安装tomcat7,安装c/c++版本的eclipse

今天费率好多功夫,终于装上来,现在想想,其实也不难,只需以下几个步骤就可。                  安装JDK1.7,安装eclipse,安装tomcat7,安装c/c++版本的e...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:深度学习:神经网络中的前向传播和反向传播算法推导
举报原因:
原因补充:

(最多只允许输入30个字)