HDU 5058 So easy(STL 集合set的运用)

 Problem Description
Small W gets two files. There are n integers in each file. Small W wants to know whether these two files are same. So he invites you to write a program to check whether these two files are same. Small W thinks that two files are same when they have the same integer set.
For example file A contains (5,3,7,7),and file B contains (7,5,3,3). They have the same integer set (3,5,7), so they are same.
Another sample file C contains(2,5,2,5), and file D contains (2,5,2,3).
The integer set of C is (2,5),but the integer set of D is (2,3,5),so they are not same.
Now you are expected to write a program to compare two files with size of n.


Input
Multi test cases (about 100). Each case contain three lines. The first line contains one integer n represents the size of file. The second line contains n integers a1,a2,a3,…,an - represents the content of the first file. The third line contains n integers b1,b2,b3,…,bn - represents the content of the second file.
Process to the end of file.
1≤n≤100
1≤ai,bi≤1000000000


Output
For each case, output "YES" (without quote) if these two files are same, otherwise output "NO" (without quote).


Sample Input
3
1 1 2
1 2 2
4
5 3 7 7
7 5 3 3
4
2 5 2 3
2 5 2 5
3
1 2 3
1 2 4


Sample Output
YES
YES
NO
NO     

题目意思:给出两个长度都为 n 的集合你,问这两个集合是否相等。                                                                                                                                                                                                                                                                                                 

#include<cstdio>
#include<set>
using namespace std;
int main()
{
    set<int>a,b;
    int n,v,i;
    while(~scanf("%d",&n))
    {
        for(i=0;i<2*n;i++)
        {
            scanf("%d",&v);
            if(i<n)a.insert(v);
            else b.insert(v);

        }
        if(a==b)
            puts("YES");
        else
            puts("NO");
        a.clear();b.clear();
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值