nyoj fibonacci数列(二) 矩阵乘法

http://acm.nyist.net/JudgeOnline/problem.php?pid=148

fibonacci数列(二)

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

输入
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.
输出
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).
样例输入
0
9
1000000000
-1
样例输出
0
34
6875


当年做的这道~~都忘了差不多了~~ 大矩阵的乘法~~再用递归求解就可以得到了。


#include<stdio.h>
struct node{
           int a11,a12,a21,a22;
           }num,a;
node matrix(node a,node b)   //矩阵乘法应用
{
    node c;
    c.a11= (a.a11*b.a11%10000  + a.a12*b.a21%10000)%10000;
    c.a12= (a.a11*b.a12%10000 + a.a12*b.a22%10000)%10000;
    c.a21= (a.a21*b.a11%10000 + a.a22*b.a21%10000)%10000;
    c.a22= (a.a21*b.a12%10000 + a.a22*b.a22%10000)%10000;
    return c;     
}
node fun(int n)
{    
     if(n==1)return a;
     node c=fun(n/2);
     c=matrix(c,c);
     if(n%2==1)c=matrix(c,a);
     return c;
}



int main()
{

    a.a11=1,a.a12=1,a.a21=1,a.a22=0;    
   int n;
   node c;
   while(scanf("%d",&n) && n!=-1) 
   {
       if( n==0){printf("0\n");continue;} 
       if( n==1){printf("1\n");continue;}                     
       c=fun(n);     
       printf("%d\n",c.a21);
   } 
    
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值