Call requires API level 11 (current min is 7): android.app.ActionBar#setDisplayShowHomeEnabled

原创 2015年07月10日 17:27:04

【错误描述】

    在用Eclipse开发过程中,为了兼容Android2.2和4.0以上版本,我在使用Notification类时做了2个版本的代码,代码根据系统版本不同执行相应模块,结果,等我输完代码,发现系统提示了一个这么的错误。

【原因分析】

    不详,可能和Run Android Lint有点关系吧。就是创建项目时,我们设置了最低版本API Level,比如我的是8,因此,Eclipse检查我调用的API后,发现版本号不能向低版本兼容,比如我用的“Notification.Builder”是Level 11 以上才有的,自然超过了8,所以提示错误。

【解决方案】

   右键点击项目->Android tools ->Clear Link Markers.即可临时解决,但是如果调试用的模拟器是低版本的,则在调试完后还有这个错误。

  如果把manifest文件中的user-sdk的android:minSdkVersion改为报错的那个高版本就没事。比如下面:

<uses-sdk

        android:minSdkVersion="11"   //这个之前是8

        android:targetSdkVersion="17" />


 

【扩展】

  这种错误不仅发生在Level11,也同时发生于其他因为设置了最低版本,但使用了高版本API的代码中,解决方案应该相同。

版权声明:本文为博主原创文章,未经博主允许不得转载。

相关文章推荐

Android Call requires API level 11 (current min is 8)的解决方案

*【错误描述】 -在用Eclipse开发过程中,为了兼容Android2.2和4.0以上版本,我在使用Notification类时做了2个版本的代码, 代码根据系统版本不同执行相应模块,结果,等我输完...

Call requires API level 11 (current min is 8)

【错误描述】在用Eclipse开发过程中,为了兼容Android2.2和4.0以上版本,我在使用Notification类时做了2个版本的代码,代码根据系统版本不同执行相应模块,结果,等我输完代码,发...

Android(3.0,level 11)工具栏ActionBar——菜单

在上一篇博客中,已经简单介绍了ActionBar的一个常用控件SearchView,在本篇博文中,我将给大家介绍另一个常用控件:菜单。系统运行效果图: 实现思路: 重写onCreateOpti...

Android(3.0,level 11)工具栏ActionBar——搜索栏

本文介绍ActionBar中的一个常用小功能,搜索框。 实现思路: 1、重写onCreateOptionsMenu; 2、创建MenuItem,将SearchView添加到MenuItem中; 3、给...

android support v4 v7 v13 V<require min api>

Android 版本兼容  向下兼容  1.6、2.1还是占有一定的市场,故在有些时候,我们还是得要考虑兼容这些版本。    google提供了Android Support Library pa...

Android API Level在11前后及16之后时Notification的不同用法

作为刚入门Android的小白,最近在按照郭大神的《第一行代码》在练习,在用到Notification时遇到了一些问题,网上资料比较零散,我这里做了一个总结分析给各位,若有错误,恳请指正~ Notif...

关于LGame中的call to OpenGL ES API with no current context

那个,今天小弟在一位网友的邮件中,发现有另外一位网友遇到了LGame运行时log中显示call to OpenGL ES API with no current context的问题,估计这个问题挺有...

call to OpenGL ES API with no current context (logged once per thread)

背景 cocos2dx Android 工程接入移动基地的短信扣费SDK; 程序运行,扣费成功后 程序崩溃。 eclipse logcat 提示: 网上搜索到两个方法 第...

Android requires compiler compliance level 5.0 or 6.0. 出错原因分析、解决方法

开发过程中碰到了一个问题:  Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please u...

requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools Fix Pr

requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use And...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:深度学习:神经网络中的前向传播和反向传播算法推导
举报原因:
原因补充:

(最多只允许输入30个字)