POJ 1789 Truck History (最小生成树---prim)

Truck History
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 24810 Accepted: 9678

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top

题意真心看不懂。。。。
用一个7位的string代表一个编号,两个编号之间的distance代表这两个编号之间不同字母的个数。一个编号只能由另一个编号衍生出来,代价是这两个编号之间相应的distance,现在要找出一个衍生方案,使得总代价最小,也就是distance之和最小。
将问题转化为最小生成树的问题。每一个编号为图的一个顶点,顶点与顶点间的编号差即为这条边的权值,题目所要的就是我们求出最小生成树来。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define Max 2001
int map[Max][Max];
int n;
int dis[Max],vis[Max];
char str[Max][8];
int prim(int s)
{
	int i,j,k;
	memset(dis,0x7f,sizeof(dis));
	memset(vis,0,sizeof(vis));
	int sum=0;
	dis[s]=0;
	vis[s]=1;
	for(i=1;i<=n;i++)
	{
		if(map[s][i]!=-1&&map[s][i]<dis[i])
		dis[i]=map[s][i];
	}
	for(i=1;i<n;i++)
	{
		int flag=-1;
		int Min=999999;
		for(j=1;j<=n;j++)
		{
			if(!vis[j]&&dis[j]<Min)
			{
				Min=dis[j];
				flag=j;
			}
		}
		if(flag==-1)
		return -1;
		sum+=Min;
		vis[flag]=1;
		for(j=1;j<=n;j++)
		{
			if(!vis[j]&&map[flag][j]!=-1&&map[flag][j]<dis[j])
			dis[j]=map[flag][j];
		}
	}
	return sum;
}
int main()
{
    while(scanf("%d",&n),n)
    {
    	memset(map,-1,sizeof(map));
		for(int i=1;i<=n;i++)
		scanf("%s",str[i]);
		for(int i=1;i<=n;i++)
		{
			for(int j=i+1;j<=n;j++)
			{
				int num=0;
				for( int k=0;k<7;k++)
		        {
			        if(str[i][k]!=str[j][k])
			        num++;
		        }
		        map[i][j]=map[j][i]=num;
			}
		    
		}
		printf("The highest possible quality is 1/%d.\n",prim(1));
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值