关闭

安装cocoapods,遇到ERROR: Error installing cocoapods: activesupport requires Ruby version >= 2.2)

标签: iOSrubycocoapods
394人阅读 评论(0) 收藏 举报
分类:

在安装cocoa pods,提示ruby版本低了,需要更新版本

安装cocoapods,遇到ERROR: Error installing cocoapods: activesupport requires Ruby version >= 2.2)

第一个问题可以点击看这个http://blog.csdn.net/fairytale_1/article/details/51850734

然后安装了RVM,安装之后又出现了rvm command not  found

第二个问题可以看这个http://stackoverflow.com/questions/11677771/rvm-command-not-found-mac-ox

其实就需要添加下面

source /Users/当前用户名称/.rvm/scripts/rvm




0
0
查看评论

关于安装cocoapods遇到的一些坑(ERROR: Error installing cocoapods: activesupport requires Ruby version >= 2.2)

1.移除现有的Ruby $gem sources --remove https://rubygems.org/ 2.使用淘宝镜像 $gem sources -a https://ruby.taobao.org/ 3.验证当前ruby版本 $gem sources -l 成功后...
  • fairytale_1
  • fairytale_1
  • 2016-07-07 13:59
  • 16247

cocoapods的安装 遇到 Error installing pods:activesupport requires Ruby version >=2.2.2

参考博客地址如下: 1:http://blog.csdn.net/lissdy/article/details/9191351 2:http://www.cnblogs.com/yan520/p/5583362.html 3:http://www.jianshu.com/p/6e5c0f782...
  • fly601845
  • fly601845
  • 2016-08-08 17:16
  • 2859

Ruby On Rails 安装

macOS 上面安装 Rails 其实就一句话咯。—— 但是坑太多了,一句话是远远不够的。$ gem install railsmacOS 自身已经安装了 Ruby 了,版本应该比较低的,直接按照上面命令安装,会提示 Ruby 版本不够的错误信息:ERROR: Error installing r...
  • ShengQiangLiu
  • ShengQiangLiu
  • 2016-09-03 14:07
  • 1172

解决 安装cocoapods失败,提示 requires Ruby version >=2.2.2

上个月试了一个程序员终极必杀技:rm -rf /       至今后遗症都没有消除,电脑空空如也,所有项目我都得重新过一遍,有些客户管理的证书,我只能厚着脸皮去要了。。。说实话,现在我在这里写“rm -rf /”的时候都不敢轻易回车!!!&...
  • u010731949
  • u010731949
  • 2016-07-04 16:32
  • 5422

安装完ruby环境后,安装redis接口时报错:redis requires Ruby version >= 2.2.2.的解决

在执行gem install redis时,报错: gem install redis ERROR: Error installing redis: redis requires Ruby version >= 2.2.2.这句话的意思是,安装redis需要...
  • zhaoyahui_666
  • zhaoyahui_666
  • 2017-12-05 10:13
  • 313

Redis安装ruby报错:Error installing redis: redis requires Ruby version >= 2.2.2.

Redis安装ruby报错:Error installing redis: redis requires Ruby version >= 2.2.2.【解决】
  • a515557595_xzb
  • a515557595_xzb
  • 2017-12-15 10:49
  • 328

redis requires Ruby version >= 2.2.2

在执行gem install redis时 提示: gem install redis ERROR: Error installing redis: redis requires Ruby version >= 2.2.2.查了查资料,CentOS7 ...
  • FengYe_YuLu
  • FengYe_YuLu
  • 2017-08-28 02:40
  • 8159

关于安装cocoapods遇到的一些坑(ERROR: Error installing cocoapods: activesupport requires Ruby version >= 2.2)

这个是网上找的解决的办法,搞了一个多小时才搞出来,恶心死了,不多最终还是搞出来了,1.移除现有的Ruby $gem sources –remove https://rubygems.org/ 2.使用淘宝镜像 $gem sources -a https://ruby.taobao.org/ ...
  • iOS_MingXing
  • iOS_MingXing
  • 2016-08-14 22:33
  • 901

CenterOS7——报错redis requires Ruby version -= 2.2.2

安装ruby环境 yum install ruby yum install rubygems 安装redis-trib.rb运行依赖的ruby的包redis-3.2.2.gem 下载地址:https://rubygems.global.ssl.fastly.net/gems/redis-4.0...
  • qq_37595946
  • qq_37595946
  • 2017-09-02 11:40
  • 3078

iOS ERROR: Error installing cocoapods: activesupport requires Ruby version >= 2.2.2

一、原因:ruby版本太低二、解决方案: 1.安装ruby需要先安装rvm:curl -L https://get.rvm.io | bash -s stable –ruby (可以先用rvm -v查看一下版本号)2.source ~/.rvm/scripts/rvm3.rvm -v(可以使用这个...
  • sgliquangang
  • sgliquangang
  • 2016-11-21 14:53
  • 380
    个人资料
    • 访问:29561次
    • 积分:857
    • 等级:
    • 排名:千里之外
    • 原创:58篇
    • 转载:0篇
    • 译文:0篇
    • 评论:1条
    文章分类
    最新评论