HDOJ 233 Matrix 5015【矩阵快速幂】



233 Matrix

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1355    Accepted Submission(s): 806


Problem Description
In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 ... in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be 233, 2333, 23333... (it means a 0,1 = 233,a 0,2 = 2333,a 0,3 = 23333...) Besides, in 233 matrix, we got a i,j = a i-1,j +a i,j-1( i,j ≠ 0). Now you have known a 1,0,a 2,0,...,a n,0, could you tell me a n,m in the 233 matrix?
 

Input
There are multiple test cases. Please process till EOF.

For each case, the first line contains two postive integers n,m(n ≤ 10,m ≤ 10 9). The second line contains n integers, a 1,0,a 2,0,...,a n,0(0 ≤ a i,0 < 2 31).
 

Output
For each case, output a n,m mod 10000007.
 

Sample Input
      
      
1 1 1 2 2 0 0 3 7 23 47 16
 

Sample Output
      
      
234 2799 72937
Hint
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5390  5389  5388  5387  5386 
 


题意:求矩阵anm的元素,第一行0,233,2333,23333,。。。。然后给n个元素代表第i行第一列,ai0 元素.....   aij = ai-1,j+ai,j-1 ....就根据这个公式算出所有元素。然后输出anm 。

解题分析:

此题一看就是裸快速幂~因为m比较大。开始的时候是想直接推算出整个矩阵,后来发现推不出来。然后就得想到推下一列。就是有第一列推第二列,第二列推第三列。。。。等等。。

我们先写几个元素 

a[1]

a[2]

a[3]

想到有233~得出来这个数啊。

23

a[1]

a[2]

a[3]

3

推下一列有:

23*10+3

a[1]+23*10+3

a[2]+a[1]+23*10+3

a[3]+a[2]+a[1]+23*10+3

3

然后转移矩阵A就可以推出来了:

10 0 0 0 1

10 1 0 0 1

10 1 1 0 1

10 1 1 1 1

 0  0 0 0 1


然后对A求快速幂,再乘以a数列就可以了


#include <stdio.h>
#include <math.h>
#include <vector>
#include <queue>
#include <string>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>

using namespace std;

typedef long long LL;
const int Modn = 10000007;
const int MAXN = 15;
LL res[MAXN][MAXN];
int N;

void Matmul(LL X[MAXN][MAXN],LL Y[MAXN][MAXN])
{
    LL t[MAXN][MAXN]={0};
    for(int i=0;i<N;i++)
        for(int k=0;k<N;k++)
            if(X[i][k])
            for(int j=0;j<N;j++)
            t[i][j]=(t[i][j]+X[i][k]*Y[k][j]%Modn)%Modn;
    for(int i=0;i<N;i++)
        for(int j=0;j<N;j++)
            X[i][j]=t[i][j];
}

void Matrix(LL X[MAXN][MAXN],LL n)
{
    for(int i=0;i<N;i++)
        for(int j=0;j<N;j++)
        res[i][j]=(i==j);
    while(n){
        if(n&1) Matmul(res,X);
        Matmul(X,X);
        n>>=1;
    }
}

int main()
{
    LL n;
    LL m;
    while(scanf("%lld%lld",&n,&m)!=EOF){
        LL a[MAXN];
        LL A[MAXN][MAXN];
        memset(A,0,sizeof(A));
        N=n+2;
        for(int i=1;i<=n;i++)
            scanf("%lld",&a[i]);
        a[0]=23;a[n+1]=3;
        for(int i=0;i<N;i++){
            if(i!=N-1)A[i][0]=10;
            for(int j=1;j<=i;j++){
                if(i!=N-1)A[i][j]=1;
            }
            A[i][N-1]=1;
        }
        Matrix(A,m);
        LL ans=0;
        //for(int i=0;i<N;i++)
        for(int j=0;j<N;j++){
                ans=(ans+a[j]*res[N-2][j]%Modn)%Modn;
        }
        printf("%lld\n",ans);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值