hdu1509

hdu优先队列

Windows Message Queue

Problem Description
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

Input
There’s only one test case in the input. Each line is a command, “GET” or “PUT”, which means getting message or putting message. If the command is “PUT”, there’re one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

Output
For each “GET” command, output the command getting from the message queue with the name and parameter in one line. If there’s no message in the queue, output “EMPTY QUEUE!”. There’s no output for “PUT” command.

Sample Input
GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET

Sample Output
EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!
题解:
定义一个node保存信息,当输入GET时就从优先队列中取出一个信息,没有信息输出EMPTY QUEUE!,当输入PUT是就将一条信息插入到优先队列中,插入的依据先按优先级插入,如果优先级相等再根据消息的先后时间插入到优先队列中,一下是本人手写的优先队列的插入和取数操作。已AC

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string>
using namespace std;
struct node{
    char a[20];
    int  para;
    int pri;
    long int time; 
};
typedef struct node * PNode;
struct PriorityQueue{
    PNode *pq;
    int n;
};
typedef struct PriorityQueue *PPriorityQueue;
void add_heap(PPriorityQueue papq,PNode p){
    int i;
        for(i=papq->n;i>0&&((papq->pq[(i-1)/2]->pri>p->pri)||(papq->pq[(i-1)/2]->pri==p->pri&&papq->pq[(i-1)/2]->time>p->time));i=(i-1)/2){
            papq->pq[i]=papq->pq[(i-1)/2];
        }
        papq->pq[i]=p;
        papq->n++;
}
void removeMin_heap(PPriorityQueue papq){

    if(papq->n!=0){
        int s,child=1,i=0;
        PNode q;
        s=--papq->n;
        q=papq->pq[s];
        while(child<s){
            if(child<s-1&&papq->pq[child]->pri>papq->pq[child+1]->pri)
            child++;
            if(child<s-1&&papq->pq[child]->pri==papq->pq[child+1]->pri&&papq->pq[child]->time>papq->pq[child+1]->time)
            child++;
            if((q->pri>papq->pq[child]->pri)||(q->pri==papq->pq[child]->pri&&q->time>papq->pq[child]->time)){
                papq->pq[i]=papq->pq[child];
                i=child;
                child=2*i+1;
            }
            else break;
        }
        papq->pq[i]=q;
    }
}
void get(PPriorityQueue papq){
    if(papq->n==0){
        cout<<"EMPTY QUEUE!"<<endl;
    }
    else{

        cout<<papq->pq[0]->a<<" "<<papq->pq[0]->para<<endl;
        removeMin_heap(papq);
    }
}
int main(){
    long int time=0;
    PPriorityQueue papq=(PPriorityQueue)malloc(sizeof(struct PriorityQueue));
    papq->n=0;
    papq->pq=(PNode *)malloc(sizeof(struct node)*60003);

    string s;
    while(cin>>s){
        if(s.compare("GET")==0){
            get(papq);
        }
        if(s.compare("PUT")==0){
            PNode q=(PNode)malloc(sizeof(struct node));
            cin>>q->a>>q->para>>q->pri;
            q->time=time;
            add_heap(papq,q);
            time++;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值