POJ 1742 Coins(多重背包)

Coins
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 

Input

The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 

Output

For each test case output the answer on a single line.
 

Sample Input

     
     
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 

Sample Output

     
     
8 4
 


#include<stdio.h>
#include<string.h>
#include<algorithm>
int v[110];
int w[110];
int dp[100005];
using namespace std;
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0&&m==0)
        {
            break;
        }
        memset(v,0,sizeof(v));
        memset(w,0,sizeof(w));
        for(int i=1; i<=100005; i++)
        {
            dp[i]=-9999999;
        }
        dp[0]=1;
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&v[i]);
        }
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&w[i]);
        }
        for(int i=1; i<=n; i++)
        {
            if(v[i]*w[i]>=m)
            {
                for(int j=v[i]; j<=m; j++)
                {
                    dp[j]=max(dp[j],dp[j-v[i]]+v[i]);
                    //printf("%d %d\n",j,dp[j]);
                }
            }
            else
            {
                for(int k=1; k<=w[i]; k=k*2)
                {
                    for(int j=m; j>=v[i]*k; j--)
                    {
                        dp[j]=max(dp[j],dp[j-v[i]*k]+v[i]*k);
                    }
                    w[i]-=k;
                }
                if(w[i]>0)
                {
                    for(int j=m; j>=v[i]*w[i]; j--)
                        dp[j]=max(dp[j],dp[j-v[i]*w[i]]+v[i]*w[i]);
                }
            }
        }
        int count=0;
        for(int i=1; i<=m; i++)
        {
            if(dp[i]>=0)
                count++;
        }
        printf("%d\n",count);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值