POJ 3067 Japan(树状数组/求逆序数)

Japan
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 22258 Accepted: 5995

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5

Source




#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

int n,m,k;
__int64 c[1000100];

struct node
{
    int x;
    int y;
} q[1000500];

bool cmp(node a,node b)
{
    if(a.x==b.x)
    {
        return a.y<=b.y;
    }
    else
    {
        return a.x<b.x;
    }
}
int lowbit(int x)
{
    return x&(-x);
}

void updata(int i,int t)
{
    while(i<=m)
    {
        c[i] += t;
        i = i + lowbit(i);
    }
}

__int64 getsum(int i)
{
    __int64 sum = 0;
    while(i>0)
    {
        sum += c[i];
        i = i - lowbit(i);
    }
    return sum;
}

int main()
{
    int T;
    int p = 0;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&m,&k);
        memset(c,0,sizeof(c));
        for(int i=0; i<k; i++)
        {
            scanf("%d%d",&q[i].x,&q[i].y);
        }
        __int64 ans = 0;
        sort(q,q+k,cmp);
        for(int i=0; i<k; i++)
        {
            updata(q[i].y,1);
            ans += getsum(m) - getsum(q[i].y);
        }
        printf("Test case %d: %I64d\n",++p,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值