06-图2 Saving James Bond - Easy Version   (25分)

2 篇文章 0 订阅

This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape -- he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head... Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers (100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x, y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:

For each test case, print in a line "Yes" if James can escape, or "No" if not.

Sample Input 1:

14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12

Sample Output 1:

Yes

Sample Input 2:

4 13
-12 12
12 12
-12 -12
12 -12

Sample Output 2:

No

解析:用邻接矩阵或邻接表会比较麻烦,必须先计算所有结点间的距离再和007的跳跃距离比较,才能构建图的边。使用Jump函数和FirstJump函数来判断两个结点之间是否有边,可以省去存储边的麻烦。

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
int N, D;
int Visited[105];
struct Crocodile {
	int x, y;
} cro[105];
double ComputeDistance( int a, int b ) {
	double x = abs( cro[a].x - cro[b].x ); 
	double y = abs( cro[a].y - cro[b].y );
	return sqrt( x * x + y * y );
}
int FirstJump( struct Crocodile dot ) {
	double temp = dot.x * dot.x + dot.y * dot.y;
	double dis = sqrt( temp );
	double cap = 7.5 + D;	//第一次跳要加上小岛的半径
	if( cap >= dis ) return 1;
	else return 0;
}
int Jump( int a, int b ) {
	double dis = ComputeDistance(a, b);
	if( D >= dis) return 1;
	else return 0;
}
//v点是否能直接跳上岸边
int IsSafe( int v ) {
	int x = abs( cro[v].x );
	int y = abs( cro[v].y );
	if( x + D >= 50 || y + D >= 50 )
		return 1;
	else return 0;
}
//DFS改编
int DFS(int v) {
	int answer = 0;
	Visited[v] = 1;
	if( IsSafe(v) ) answer = 1;
	else {
		for(int i = 0; i < N; i++)
			if( !Visited[i] && Jump(v, i) ) {   //Jump来判断是否是邻接的结点(与邻接矩阵有着相同的作用)
				answer = DFS(i);
				if(answer == 1) break;
			}
	}
	return answer;
}
//计算连通集个数 改编
void Save007() {
	int answer = 0;
	for(int i = 0; i < N; i++) {
		if (!Visited[i] && FirstJump(cro[i])) {
			answer = DFS(i);
			if (answer == 1) break;
		}
	}
	if (answer == 1) printf("Yes");
	else printf("No");
}
int main(){
	scanf("%d %d", &N, &D);
	for(int i = 0; i < N; i++)
		scanf("%d %d", &cro[i].x, &cro[i].y);
	Save007();
	system("pause");
	return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值