LA3027 - Corporative Network,并查集

A very big corporation is developing its corporative network. In the beginning each of the Nenterprises of the corporation, numerated from 1 to N, organized its own computing andtelecommunication center. Soon, for amelioration of the services, the corporation started to collectsome enterprises in clusters, each of them served by a single computing and telecommunicationcenter as follow. The corporation chose one of the existing centers I (serving the cluster A) andone of the enterprises J in some cluster B (not necessarily the center) and link them withtelecommunication line. The length of the line between the enterprises I and J is |I � J|(mod 1000).In such a way the two old clusters are joined in a new cluster, served by the center of the old clusterB. Unfortunately after each join the sum of the lengths of the lines linking an enterprise to its servingcenter could be changed and the end users would like to know what is the new length. Write aprogram to keep trace of the changes in the organization of the network that is able in eachmoment to answer the questions of the users.

Input 

Your program has to be ready to solve more than one test case. The first line of the input file willcontains only the number T of the test cases. Each test will start with the number N of enterprises(5≤N≤20000). Then some number of lines (no more than 200000) will follow with one of thecommands:
E I � asking the length of the path from the enterprise I to its serving center in the moment;
I I J � informing that the serving center I is linked to the enterprise J.
The test case finishes with a line containing the word O. The I commands are less than N.

Output 

The output should contain as many lines as the number of E commands in all test cases with asingle number each � the asked sum of length of lines connecting the corresponding enterprise withits serving center.

Sample Input 

1
4
E 3
I 3 1
E 3
I 1 2
E 3
I 2 4
E 3
O

Sample Output 

0
2
3
5
  


思路:添加d[i]数组表示结点i到父节点的距离。。。

#include <cstdio>
#include <algorithm>
using namespace std;

const int maxn = 20000 + 10;
int pa[maxn], d[maxn];

int find(int x) {
    if(pa[x] != x){
        int root = find(pa[x]);
        d[x] += d[pa[x]];
        return pa[x] = root;
    }else return x;
}

int main()
{
    int T;
    scanf("%d", &T);
    while(T--){
        int n, u, v;
        char cmd[9];
        scanf("%d", &n);
        for(int i=1; i<=n; i++){pa[i] = i; d[i] = 0;}
        while(scanf("%s",cmd) && cmd[0] !='O'){
            if(cmd[0] == 'E'){scanf("%d", &u); find(u); printf("%d\n", d[u]);}
            if(cmd[0] == 'I'){scanf("%d%d", &u, &v);pa[u] = v; d[u] = abs(u-v) % 1000;}
        }
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值