杭电oj-1164-Eddy's research I

Problem Description
Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .

Input
The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.

Output
You have to print a line in the output for each entry with the answer to the previous question.

Sample Input
11
9412
Sample Output
11
2*2*13*181
题目的意思是给你一个整数x(1<x<=65535),让你写出x的素数因数乘积式,如果本身x是素数,则直接输出x。
分析:这是一道简单的素数筛选题,用Eratosthenes优化筛法筛出素数表,剩下查表就ok了,注意不要忘了有的数有多个相同素数因子。
代码如下:
#include <stdio.h>
#include <math.h>
#define MAX 70000
int a[MAX+1];
int prime[MAX+1];
int k=0;
//素数筛选
void shaixuan()
{
    prime[k]=2;
    for(int i=3;i<=MAX;i+=2)
        a[i]=0;
    for(int i=3;i<=sqrt(MAX+0.5);i+=2)
        if(a[i]==0)
            for(int j=i*i;j<=MAX;j+=i*2)
                a[j]=1;
    for(int i=3;i<=MAX;i+=2)
        if(a[i]==0)
            prime[++k]=i;
}
int main()
{
    shaixuan();
    int x;
    while(scanf("%d",&x)!=-1)
    {
        int i=0;
        for(int i=0;i<k;i++)
        {
            //如果是素数,直接输出,换行结束
            if(x==prime[i])
            {
                printf("%d",x);
                printf("\n");
                break;
            }
            //如果不是素数,则输出“素数*”,并且自身除去素数
            if(x%prime[i]==0)
            {
                printf("%d*",prime[i]);
                x/=prime[i];
                //i需要自减,为了不再次重头再查素数表,可能当前素数有几个,比如9=3*3
                i--;
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值