gre tunnel实验(GNS3)

配置文件:


拓扑图:



(1) net文件:

autostart = False
[localhost:7200]
    workingdir = /home/chen/gns3workdir
    udp = 10000
    [[7200]]
        image = /mnt/e/study/cisco/Cisco/Others/c7200/c7200-advipservicesk9-mz.124-2.T.bin
        idlepc = 0x610eaf20
        ghostios = True
    [[ROUTER R5]]
        console = 2006
        slot1 = PA-4T+
        s1/0 = R0 s1/0
        s1/1 = R2 s1/1
        x = -198.0
        y = -112.0
    [[ROUTER R0]]
        console = 2000
        f0/0 = NIO_udp:5004:127.0.0.1:5005
        slot1 = PA-4T+
        s1/0 = R5 s1/0
        slot2 = PA-FE-TX
        x = -384.0
        y = -122.0
[localhost:7201]
    workingdir = /home/chen/gns3workdir
    udp = 10100
    [[7200]]
        image = /mnt/e/study/cisco/Cisco/Others/c7200/c7200-advipservicesk9-mz.124-2.T.bin
        idlepc = 0x610eaf20
        ghostios = True
    [[ROUTER R2]]
        console = 2002
        slot1 = PA-4T+
        s1/0 = R3 s1/0
        s1/1 = R5 s1/1
        slot2 = PA-FE-TX
        x = -25.0
        y = -126.0
        hx = 27.0
        hy = -27.0
    [[ROUTER R3]]
        console = 2003
        f0/0 = NIO_udp:5006:127.0.0.1:5007
        slot1 = PA-4T+
        s1/0 = R2 s1/0
        slot2 = PA-FE-TX
        x = 163.0
        y = -118.0
[GNS3-DATA]
    [[Cloud C2]]
        x = -499.5
        y = 30.0
        connections = R0:f0/0:nio_udp:5004:127.0.0.1:5005
    [[Cloud C3]]
        x = 157.5
        y = 33.0
        connections = R3:f0/0:nio_udp:5006:127.0.0.1:5007
    [[NOTE 1]]
        text = 172.16.4.4/24
        x = 235.0
        y = -25.0
        rotate = 0
    [[NOTE 2]]
        text = 61.0.0.4/24
        x = 132.0
        y = -157.0
        rotate = 0
    [[NOTE 3]]
        text = 172.16.1.1/24
        x = -420.0
        y = -42.0
        rotate = 0
    [[NOTE 4]]
        text = 61.0.0.3/24
        x = 13.0
        y = -50.0
        rotate = 0
    [[NOTE 5]]
        text = 218.30.1.3/24
        x = -67.0
        y = -170.0
        rotate = 0
    [[NOTE 6]]
        text = 218.30.1.2/24
        x = -189.0
        y = -163.0
        rotate = 0
    [[NOTE 7]]
        text = 202.96.134.2/24
        x = -225.0
        y = -40.0
        rotate = 0
    [[NOTE 8]]
        text = 202.96.134.1/24
        x = -384.0
        y = -180.0
        rotate = 0

(2)路由配置文件:

R0.cfg: 

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel0
 ip address 172.16.14.1 255.255.255.0
 tunnel source Serial1/0
 tunnel destination 61.0.0.4
!
interface FastEthernet0/0
 ip address 172.16.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex half
!
interface Serial1/0
 ip address 202.96.134.1 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex half
!
router rip
 version 2
 network 172.16.0.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial1/0
no ip http server
no ip http secure-server
!
!
ip nat inside source list 10 interface Serial1/0 overload
!
access-list 10 permit 172.16.1.0 0.0.0.255
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 stopbits 1
line aux 0
line vty 0 4
!
!
end


R2.cfg:

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface Serial1/0
 ip address 61.0.0.3 255.255.255.0
 serial restart-delay 0
 clock rate 64000
!
interface Serial1/1
 ip address 218.30.1.3 255.255.255.0
 serial restart-delay 0
 clock rate 64000
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex half
!
router rip
 version 2
 network 61.0.0.0
 network 218.30.1.0
!
ip classless
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 stopbits 1
line aux 0
line vty 0 4
!
!
end


-----------------------------------

R3.cfg:

-----------------------------------

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel0
 ip address 172.16.14.4 255.255.255.0
 tunnel source Serial1/0
 tunnel destination 202.96.134.1
!
interface FastEthernet0/0
 ip address 172.16.4.4 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex half
!
interface Serial1/0
 ip address 61.0.0.4 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex half
!
router rip
 version 2
 network 172.16.0.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial1/0
no ip http server
no ip http secure-server
!
!
ip nat inside source list 10 interface Serial1/0 overload
!
access-list 10 permit 172.16.4.0 0.0.0.255
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 stopbits 1
line aux 0
line vty 0 4
!
!
end


------------------------------

R5.cfg:

-----------------------------

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface Serial1/0
 ip address 202.96.134.2 255.255.255.0
 serial restart-delay 0
 clock rate 64000
!
interface Serial1/1
 ip address 218.30.1.2 255.255.255.0
 serial restart-delay 0
 clock rate 64000
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router rip
 version 2
 network 202.96.134.0
 network 218.30.1.0
 no auto-summary
!
ip classless
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 stopbits 1
line aux 0
line vty 0 4
!
!
end

-------------------------------------------------


结果:



----------------------------------------------------------------------------------------------------------

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
From installation through to creating large scale simulations, this is the complete guide to GNS3 that will give you the know-how needed for Cisco certification. For networking professionals, it’s a career-advancing tutorial. Overview Develop your knowledge for Cisco certification (CCNA, CCNP, CCIE), using GNS3 Install GNS3 successfully on Windows, Linux, or OS X Work your way through easy- to- follow exercises showing you how to simulate your test network using Cisco routers, Ethernet switches, and Virtual PCs Expand your existing simulations by including PCs running in Qemu or VirtualBox VMs, Cisco ASAs, Juniper routers, and Vyatta routers Increase your networking knowledge by learning how GNS3 orchestrates multiple hypervisors, simulators, and real-world live connections In Detail GNS3 is an open-source Graphical Network Simulator used extensively by networking professionals to simulate networking devices such as Cisco, Juniper and Vyatta routers, along with Virtual PCs. GNS3 Network Simulation Guide gives you all the information you need to run a successful GNS3 simulation. You will be guided through the tricky installation pre-requisites and procedures involved in developing a simulated topology suitable for studying for Cisco CCIE Certification. We will also cover many useful tips and tricks which will help you make the most of your GNS3 simulator application. You will begin the GNS3 journey by ensuring that you have prepared your computer with any additional files required by GNS3, to set up the simulated environment needed for a successful installation process. Once GNS3 is installed, you will get to work creating a successful simulation including routers, Ethernet switches, Virtual PCs, and capture packets using Wireshark. Next, you will learn how to master GNS3's Graphical User Interface as well as the Command Console. The inner workings of GNS3 are described in depth so that you gain an appreciation of how UDP tunnels are used to tie the many components of GNS3 together. By following the clear examples and exercises in this guide, you will learn everything that you need to know about how to use GNS3 to prepare for certifications, as well as simulate real-world network scenarios. What you will learn from this book Install GNS3 on Windows, OS X, and Linux Build simulations using Cisco routers, layer 3 switches, and Virtual PCs Master the GNS3 Graphical User Interface Tweak your favourite virtual terminal application , so that it will work with GNS3 Examine your simulated traffic with Wireshark Manage your project’s files and directories Include virtualized Windows or Linux computers into your simulations Simulate Juniper and Vyatta routers Learn about the GNS3 orchestration process which allows multiple simulated devices to communicate with each other Debug using the GNS3 command console Create complex multi-hosted environments for large scale simulations Approach GNS3 Network Simulation Guide is an easy-to-follow yet comprehensive guide which is written in a tutorial format helping you grasp all the things you need for accomplishing your certification or simulation goal.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值