Weblogic 9不能兼容JPA2.0设置

原创 2016年06月02日 09:38:31

  1. 从高版本的Weblogic找到相关的jar架包,javax.persistence_1.1.0.0_2-0.jar与com.oracle.jpa2support_1.0.0.0_2-1.jar,并拷入到现有Weblogic安装目录中的modules文件夹中。
  2. 在当前定义的域下的setDomainEnv.cmd中添加以下代码,从而改变jar架包的加载顺序,在文件的顶部添加JPA 2.0架包的安装路径定义,代码如下:

set WLS_MODULES=%WL_HOME%\modules  

set PRE_CLASSPATH=%WLS_MODULES%\javax.persistence_1.1.0.0_2-0.jar;%WLS_MODULES%\com.oracle.jpa2support_1.0.0.0_2-1.jar


3.找到setDomainEnv.cmd的CLASSPATH定义,将PRE_CLASSPATH加到CLASSPATH定义的最后。
版权声明:本文为博主原创文章,未经博主允许不得转载。

相关文章推荐

Weblogic 兼容JPA相关架包架包

  • 2016年06月02日 10:00
  • 130KB
  • 下载

强制将IE8 IE9设置为IE7兼容模式来解析

英文原文:http://msdn.microsoft.com/en-us/library/cc288325(VS.85).aspx 文件兼容性用于定义让IE如何编译你的网页。此文件解释文件兼容性...

使用X-UA-Compatible来设置IE8/IE9兼容模式

英文原文:http://msdn.microsoft.com/en-us/library/cc288325(VS.85).aspx 文件兼容性用于定义让IE如何编译你的网页。此文件解释文件兼容性...

xcode7,ios9 部分兼容设置

神奇的苹果公司,再一次让程序员中枪。 一、xcode7 新建的项目,Foundation下默认所有http请求都被改为https请求. HTTP+SSL/TLS+TCP = HTTPS 也就是说...

<Ejb3InAction> Sample02 for Weblogic - Simple example of Stateless, Stateful, MDB and JPA Enity

0. Prerequisite Actually this sample is postponed, please reference to prerequisites of sample03 a...
  • sun_xo
  • sun_xo
  • 2017年03月22日 15:12
  • 90
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:Weblogic 9不能兼容JPA2.0设置
举报原因:
原因补充:

(最多只允许输入30个字)