HDU 5448 Marisa’s Cake(n个点中任意点组成的多边形面积之和)

Marisa’s Cake

Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 263    Accepted Submission(s): 151


Problem Description
Today is Marisa’s birthday and she is given a cake the shape of a convex polygon of  n  vertices. Furthermore, all the  n  vertices are all going to be on integer points of the Cartesian coordinate system. Marisa asks her friend Reimu to randomly cut off some vertices of the cake. The set of vertices chosen to be cut off has size at most  n3 , and all possible choices have the same probability to be picked up. In order to remove all chosen vertices, Reimu might cut the cake several times. Since Reimu is a perfectionist, she will always cut the cake from one vertex to another. Hence, Reimu’s cutting will not generate vertices which are not in the original polygon.

Marisa wants to know the expected size of the cake she might get, and because you are madly in love with her, you decided to do anything she wants for her! You take out your laptop and are ready to calculate the expected size for Marisa. However, Marisa is bad with fractions. She wants to make sure the answer she gets is always an integer. To do that, she would like you to multiply the answer with the total number of possible cakes there are. Unfortunately, that still doesn’t guarantee the answer be an integer. An additional 2 must also be multiplied into the answer as well. For example, let  A=(0,0),B=(1,0),C=(1,1),D=(0,2)  and  ABCD  is the shape of Marisa’s birthday cake. There are  5  possible pieces  ABCD,ABC,BCD,CDA,DAB  that Marisa might get, and the corresponding area of these convex polygons are  32,12,12,1,1  respectively. The expected size of the cake that Marisa might get is  (32+12+12+1+1)÷5=910  , and what you should tell Marisa  910×5×2=9 . Calculate the answer for Marisa and who knows, maybe she would love you back!
 

Input
The first line on the input contains an integer  T(T10) . There will be  T  test cases. The first line of each test case contains an integer  n(3n100000) indicating the number of vertices of the convex polygon. The  ith  of the following  n  lines contains two integers  xi  and  yi(0x,y109)  separated by a blank.  (xi,yi)  is the  ith  vertex of the convex polygon, and  (x1,y1),...,(xn,yn)  will be in counterclockwise order.
 

Output
For each test case, output a number as the answer. In case the answer is greater than  1000000006 , please modulo the answer with  1000000007 . (You might figure out by now that Marisa is not good at dealing with large numbers either)
 

Sample Input
  
  
2 4 0 0 1 0 1 1 0 2 5 1 1 3 1 3 2 2 3 1 2
 

Sample Output
  
  
9 50
 

Source

题目大意:给你n个点,求这些点构成的任意多边形的面积之和乘以二。
看了很多大神的代码感觉这题除了用到了几何里的叉积,其他的都是数论知识。。。
以下是参考的大神博客     大神博客入口
以下是AC代码
#include <cstdio>
using namespace std; 
typedef long long LL;
const int maxn = 100010, mod = 1000000007, inv2 = 500000004;
int t, n, pw1[maxn], pw2[maxn], x, y, pre1x, pre1y, pre2x, pre2y, ans;
int mod_add(int x, int y)
{
    x += y;
    if(x >= mod)
        x -= mod;
    return x;
}
int mod_sub(int x, int y)
{
    x -= y;
    if(x < 0)
        x += mod;
    return x;
}
int det(int x1, int y1, int x2, int y2)
{
    return mod_sub((LL)x1 * y2 % mod, (LL)x2 * y1 % mod);
}
int main()
{
    scanf("%d", &t);
    pw1[0] = 1;
    for(int i = 1; i < maxn; ++i)
        pw1[i] = (LL)pw1[i - 1] * 2 % mod; // +
    pw2[0] = 1;
    for(int i = 1; i < maxn; ++i)
        pw2[i] = (LL)pw2[i - 1] * inv2 % mod; // -
    while(t--)
    {
        scanf("%d", &n);
        pre1x = pre1y = pre2x = pre2y = ans = 0;
        for(int i = 1; i <= n; ++i)
        {
            scanf("%d%d", &x, &y);
            ans = mod_add(ans, (LL)pw1[i - 1] * det(x, y, pre2x, pre2y) % mod);
            ans = mod_add(ans, (LL)(i == n ? inv2 : pw1[n - i - 1]) * det(pre1x, pre1y, x, y) % mod);
            pre1x = mod_add(pre1x, (LL)x * pw1[i] % mod); // +
            pre1y = mod_add(pre1y, (LL)y * pw1[i] % mod); // +
            pre2x = mod_add(pre2x, (LL)x * pw2[i] % mod); // -
            pre2y = mod_add(pre2y, (LL)y * pw2[i] % mod); // -
        }
        printf("%d\n", ans);
    }
    return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值