POJ 1159 Palindrome(回文串,最长公共子序列)

Palindrome
Time Limit: 3000MS
Memory Limit: 65536K
Total Submissions: 63457
Accepted: 22128

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

Source

题目大意:给你个字符串,问最少加入多少字符可以让这个字符串变成回文字符串。
解题思路:
最少需要补充的字母数 = 原序列S的长度 —  S和e的最长公共子串长度
其中e为s的逆序字符串。
于是这题就变成了求s和e的最长公共子序列的长度。
dp[ i ][ j ]表示 s 序列的前 i 位与 e 序列的前 j 位的最长公共子序列的长度
动规方程为如果s[ i-1 ]==e[ j-1 ],那么dp[ i ][ j ]=dp[ i-1 ][ j-1 ]+1
如果不相等dp[ i ][ j ]=max(dp[ i-1 ][ j ],dp[ i ][ j-1])

这道题的字符串范围是5000,那么定义二维数组是会空间超限的,所以不能定义dp[ 5000 ][ 5000 ]
再看动态方程,会发现,对于 i 这个变量我们只用到了 i 和 i-1 。那么我们可以把它们用0和1表示,是不会有重复的;所以我定义的dp[ 2 ][ 5000] ;对每一个 i 对2取余( i % 2 );
同样对于 j 这个变量也可以用同样的方法。
AC代码
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char s[5005],e[5004];//s存入字符串,e为s的倒序 
int dp[2][5005];
int main(){
	int n;
	while(scanf("%d",&n)!=EOF){
		scanf("%s",s);
	for(int i=0;i<n;i++){
		e[i]=s[n-i-1];
	}
	memset(dp,0,sizeof(dp));
	int ans=0;
	for(int i=1;i<=n;i++){
		for(int j=1;j<=n;j++){
			if(s[i-1]==e[j-1]){
				dp[i%2][j]=dp[(i-1)%2][j-1]+1;
			}
			else{
				dp[i%2][j]=max(dp[(i-1)%2][j],dp[i%2][j-1]);
			}
			ans=max(dp[i%2][j],ans);
		}
	}
	printf("%d\n",n-ans);
	}
	return 0;
}



  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值