POJ 1080 Human Gene Functions(最长公共子序列的特别版)

Human Gene Functions
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 19782
Accepted: 11038

Description

It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them. 

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function. 
One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet. 

A database search will return a list of gene sequences from the database that are similar to the query gene. 
Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed. 

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one. 
Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity 
of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of 
the genes to make them equally long and score the resulting genes according to a scoring matrix. 

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal 
length. These two strings are aligned: 

AGTGAT-G 
-GT--TAG 

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix. 


denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9. 

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions): 

AGTGATG 
-GTTA-G 

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the 
similarity of the two genes is 14.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.

Output

The output should print the similarity of each test case, one per line.

Sample Input

2 
7 AGTGATG 
5 GTTAG 
7 AGCTATT 
9 AGCTTTAAA 

Sample Output

14
21 

Source

题目大意:

给定两组DNA序列,要你求出它们的最大相似度

每个字母与其他字母或自身和空格对应都有一个打分,求在这两个字符串中插入空格,让这两个字符串的匹配分数最大

动规方程:

dp[i][j]用来表示字符串s1  1-i的和字符串序列s2 1-j的最大相似度

value(s1[i], s2[j])表示字符s1[i]和s2[j]的匹配值

dp[i][j] = max(dp[i-1][j-1] + value(s1[i], s2[j]),     dp[i-1][j] + value(s1[i], '-'),      dp[i][j-1] + value('-', s2[j]))

最后结果位dp[ len1 ][ len2 ]

AC代码

#include <iostream>  
#include <cstdio>  
#include <cmath>  
#include <cstring>  
#include <map>  
using namespace std;  
  
const int maxn = 110;  
  
int t, len1, len2, dp[maxn][maxn], index1[maxn][5], index2[maxn][5];  
int matrix[5][5] = {{5,-1,-2,-1,-3},  
                {-1,5,-3,-2,-4},  
                {-2,-3,5,-2,-2},  
                {-1,-2,-2,5,-1},  
                {-3,-4,-2,-1,0}};  
char s1[maxn], s2[maxn];  
map<char, int> dictionary;  
  
void LCS();  
  
int main()  
{  
      
    dictionary['A'] = 0, dictionary['C'] = 1, dictionary['G'] = 2, dictionary['T'] = 3, dictionary['-'] = 4;  
      
    scanf("%d", &t);  
    while(t-- != 0)  
    {  
        scanf("%d %s", &len1, s1+1);  
        scanf("%d %s", &len2, s2+1);  
        LCS();  
        printf("%d\n", dp[len1][len2]);  
    }  
     
    return 0;  
}  
  
void LCS()  
{  
    dp[0][0] = 0;  
    for(int i = 1; i <= len1; i++)  
    {  
        dp[i][0] = matrix[dictionary[s1[i]]][dictionary['-']] + dp[i-1][0];  
    }  
    for(int j = 1; j <= len2; j++)  
    {  
        dp[0][j] = matrix[dictionary['-']][dictionary[s2[j]]] + dp[0][j-1];  
    }  
    for(int i = 1; i <= len1; i++)  
    {  
        for(int j = 1; j <= len2; j++)  
        {  
            dp[i][j] = dp[i-1][j-1] + matrix[dictionary[s1[i]]][dictionary[s2[j]]];  
            dp[i][j] = max(dp[i][j], dp[i-1][j] + matrix[dictionary[s1[i]]][dictionary['-']]);  
            dp[i][j] = max(dp[i][j], dp[i][j-1] + matrix[dictionary['-']][dictionary[s2[j]]]);  
        }  
    }  
}  



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值