POJ 3356 AGTC(经典DP最短编辑距离)

AGTC
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 13329
Accepted: 5040

Description

Let x and y be two strings over some finite alphabet A. We would like to transform x into y allowing only operations given below:

  • Deletion: a letter in x is missing in y at a corresponding position.
  • Insertion: a letter in y is missing in x at a corresponding position.
  • Change: letters at corresponding positions are distinct

Certainly, we would like to minimize the number of all possible operations.

Illustration

A G T A A G T * A G G C

| | |       |   |   | |

A G T * C * T G A C G C

Deletion: * in the bottom line
Insertion: * in the top line
Change: when the letters at the top and bottom are distinct

This tells us that to transform x = AGTCTGACGC into y = AGTAAGTAGGC we would be required to perform 5 operations (2 changes, 2 deletions and 1 insertion). If we want to minimize the number operations, we should do it like

A  G  T  A  A  G  T  A  G  G  C

|  |  |        |     |     |  |

A  G  T  C  T  G  *  A  C  G  C

and 4 moves would be required (3 changes and 1 deletion).

In this problem we would always consider strings x and y to be fixed, such that the number of letters in x is m and the number of letters in y is n where n ≥ m.

Assign 1 as the cost of an operation performed. Otherwise, assign 0 if there is no operation performed.

Write a program that would minimize the number of possible operations to transform any string x into a string y.

Input

The input consists of the strings x and y prefixed by their respective lengths, which are within 1000.

Output

An integer representing the minimum number of possible operations to transform any string x into a string y.

Sample Input

10 AGTCTGACGC
11 AGTAAGTAGGC

Sample Output

4

Source

题目大意:给你A,B两个字符串,问字符串B经过删除,增加,改变变成A字符串需要的最少步数
解题思路:

状态转移方程:
有三种情况可以导致我们上面设计的状态会发生转移。我们现在来看A[i] 和 B[j] ,
①、我们可以在 B[j]后面插入一个核苷酸(即一个字符)ch,ch==A[i],这样做的话,
至少需要 dp[i - 1][j] + 1步操作,即 dp[i][j] = dp[i - 1][j] + 1。
②、我们可以删除 B[j],这样的话,B[1...j] 变为A[1...i] 需要 dp[i][j - 1]步,
即 dp[i][j] = dp[i][j - 1] + 1。
③、我们也可以考虑修改 B[j],使它变为A[j],但是如果 B[j]本来就等于 A[i]的话,
那修改其实相当于用了 0步,如果 B[j] != A[i] 的话,那修改相当于用了 1步。
所以 dp[i][j] = dp[i - 1][j - 1] + (A[i] == B[j] ? 0, 1)。

决策:
决策就很简单了,从上面三种状态转移中选择一个最小值就可以了。

处理边界:
处理好边界非常重要,这里需要注意的是对dp[0][0....m],dp[0.....n][0]的初始化,
可以这样看,dp[0][i],就是说A[1...n]是一个空串,而B[1...m]十个长度为i的串,
很显然B串变为A串就是删除i个核苷酸。

AC代码
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
char a[1005],b[1005];
int dp[1005][1005];
int main(){
	int n,m;
	while( scanf("%d %s",&n,a+1) != EOF) {
	scanf("%d %s",&m,b+1);
	int tmp=max(n,m);
	memset(dp,0,sizeof(dp));
	for(int i=0;i<=tmp;i++){
		dp[0][i]=dp[i][0]=i;
	}
	for(int i=1;i<=n;i++){
		for(int j=1;j<=m;j++){
			dp[i][j]=min(dp[i-1][j]+1,dp[i][j-1]+1);
			if(a[i]==b[j])dp[i][j]=min(dp[i][j],dp[i-1][j-1]);
			else dp[i][j]=min(dp[i][j],dp[i-1][j-1]+1);
		}
    }
	printf("%d\n",dp[n][m]);
	}
	
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值