POJ 3045(递推找规律)

Time Limit: 1000MS Memory Limit: 65536KB 64bit IO Format: %lld & %llu

 Status

Description

Farmer John's N (1 <= N <= 50,000) cows (numbered 1..N) are planning to run away and join the circus. Their hoofed feet prevent them from tightrope walking and swinging from the trapeze (and their last attempt at firing a cow out of a cannon met with a dismal failure). Thus, they have decided to practice performing acrobatic stunts. 

The cows aren't terribly creative and have only come up with one acrobatic stunt: standing on top of each other to form a vertical stack of some height. The cows are trying to figure out the order in which they should arrange themselves ithin this stack. 

Each of the N cows has an associated weight (1 <= W_i <= 10,000) and strength (1 <= S_i <= 1,000,000,000). The risk of a cow collapsing is equal to the combined weight of all cows on top of her (not including her own weight, of course) minus her strength (so that a stronger cow has a lower risk). Your task is to determine an ordering of the cows that minimizes the greatest risk of collapse for any of the cows.

Input

* Line 1: A single line with the integer N. 

* Lines 2..N+1: Line i+1 describes cow i with two space-separated integers, W_i and S_i. 

Output

* Line 1: A single integer, giving the largest risk of all the cows in any optimal ordering that minimizes the risk.

Sample Input

3
10 3
2 5
3 3

Sample Output

2

Hint

OUTPUT DETAILS: 

Put the cow with weight 10 on the bottom. She will carry the other two cows, so the risk of her collapsing is 2+3-3=2. The other cows have lower risk of collapsing.
主要考察思维

题意:N头牛叠罗汉,每头牛有个体重Wi,力气Si.一头牛要承担的风险为所有在它上面的牛的体重之和-它的力气.

求一个方案使得风险最大的牛的风险值最小.


分析:对于相邻的两头牛,它们交换位置不影响其他的任何牛,只改变这两头牛的风险值.


记sum为这两头牛上面的牛的体重总和.i在j上面

Riski=sum-si

Riskj=sum+wi-sj

交换位置

Riski'=sum+wj-si

Riskj'=sum-sj

方案1优于方案2,则max{Riski,Riskj}<max{Riski',Riskj'}

而Riskj>Riskj'

所以Riski'>max{Riski,Riskj},且Riski'>Riskj'.

解之得

wj-si>sj

wj-si>wi-sj

wj-si>si

我们只需要中间的一条.记ti=si+wi

则方案1优于方案2等价于ti<tj,即ti小的在上会更优.

算法就简单了,排序,统计一遍就好了.


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
const int N = 50010;
typedef long long LL;
struct node
{
    LL w, s, sum;
}p[N];
int cmp(node a,node b)
{
    return a.sum<b.sum;
}


int main()
{
    int n;
    while(scanf("%d", &n)!=EOF)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%I64d %I64d", &p[i].w, &p[i].s);
            p[i].sum=p[i].w+p[i].s;
        }
        sort(p,p+n,cmp);
        LL ans=-p[0].s, cnt=0;
        for(int i=0;i<n;i++)
        {
            ans=max(ans,cnt-p[i].s);
            cnt+=p[i].w;
        }
        printf("%lld\n",ans);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值