hdu 6058 Kanade's sum(模拟)

Kanade's sum

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 494    Accepted Submission(s): 170


Problem Description
Give you an array  A[1..n] of length  n

Let  f(l,r,k)  be the k-th largest element of  A[l..r] .

Specially ,  f(l,r,k)=0  if  rl+1<k .

Give you  k  , you need to calculate  nl=1nr=lf(l,r,k)

There are T test cases.

1T10

kmin(n,80)

A[1..n] is a permutation of [1..n]

n5105
 

Input
There is only one integer T on first line.

For each test case,there are only two integers  n , k  on first line,and the second line consists of  n  integers which means the array  A[1..n]
 

Output
For each test case,output an integer, which means the answer.
 

Sample Input
  
  
1 5 2 1 2 3 4 5
 

Sample Output
  
  
30


解:找到一个点,先往右边找合法区间,再往左边找合法区间(当前值为第K大)


#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<vector>
#include<cmath>
#include<queue>
#include <bits/stdc++.h>
using namespace std;
const int N = 1e6+7;
typedef  long long LL;
const LL mod = 1e9+7;
int a[N], b[N], pos[N];

int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        int n, k;
        scanf("%d %d", &n, &k);
        for(int i=1;i<=n;i++)  scanf("%d", &a[i]);
        LL ans=0;
        for(int i=1;i<=n;i++)
        {
            if(i==8)
            {
                int h1=0;
            }
            int x=a[i], cnt=0, j, sum=0;
            b[++cnt]=i;
            for(j=i+1;j<=n&&cnt<k;j++)
                if(a[j]>x)  b[++cnt]=j;

            if(cnt==k)
            {
                int num=1;
                for(;j<=n;j++)
                {
                    if(a[j]<x) num++;
                    else break;
                }
                sum+=num;
                for(j=i-1;j>=1&&cnt>=1;j--)
                {
                    if(a[j]<x) sum+=num;
                    else
                    {
                        if(cnt==1) break;
                        num=b[cnt]-b[cnt-1];
                        cnt--;
                        sum+=num;
                    }
                }
            }
            else
            {
                for(j=i-1;j>=1&&cnt<k;j--)if(a[j]>x) b[++cnt]=j;
                if(cnt==k)
                {
                    sort(b+1,b+cnt+1);
                    int num=n-b[cnt]+1;
                    sum+=num;
                    for(;j>=1&&b[cnt]>=i;j--)
                    {
                        if(a[j]<x) sum+=num;
                        else
                        {
                            if(b[cnt]==i) break;
                            num=abs(b[cnt]-b[cnt-1]);
                            cnt--;
                            sum+=num;
                        }
                    }
                }
            }
            //printf("%d %d\n",i, sum);
            ans+=(LL)x*sum;
        }
        printf("%lld\n",ans);
    }
    return 0;
}









  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值