POJ 3253

点击打开链

Fence Repair

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 50910 Accepted: 16726

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer  N, the number of planks 
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make  N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).


先粘上问题 
题意:

有一个农夫要把一个木板钜成几块给定长度的小木板,每次锯都要收取一定费用,这个费用就是当前锯的这个木版的长度

给定各个要求的小木板的长度,及小木板的个数n,求最小费用


思路:将所有要最后需要的小木板排序,每次计算前两个的和然后与后边的数字进行比较,看该和应该放在新的数组的哪个位置会比较好。

每一次都这么循环 直到最后只剩2个数,之前所有的和的和就是这个问题的结果,应该是离散数学上的一个问题,自己感觉,用优先队列做的话会比较好但是我在这里就不粘优先队列的代码了,只看他的基本实现过程吧。

#include<stdio.h>
#include<stdlib.h>

int a[20005];

int comp(const void *a,const void *b)
{
    return *(int *)a-*(int *)b;
}

int main()
{
    int i,n;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%d",&a[i]);
    }
    qsort(a,n,sizeof(int),comp);
    int j;
    long long ans=0;
    int f=0;
    for(i=0;i<n-1;i++)
    {
        int sum=a[i]+a[i+1];
        ans+=sum;
        for(j=i+2;j<=n-1;j++)//注意这里的实现,这里是一个比较重要的优化,不然会卡掉的。
        {
            if(a[j]<sum)
                a[j-1]=a[j];
            else
            {
                a[j-1]=sum;
                f=1;
                break;
            }
        }
        if(j==n) a[j-1]=sum;
    }
    printf("%lld\n",ans);
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值