HDU 4585 Shaolin(听说兼职和尚100+/天)

8 篇文章 0 订阅

Shaolin

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1117    Accepted Submission(s): 469


Problem Description
Shaolin temple is very famous for its Kongfu monks.A lot of young men go to Shaolin temple every year, trying to be a monk there. The master of Shaolin evaluates a young man mainly by his talent on understanding the Buddism scripture, but fighting skill is also taken into account.
When a young man passes all the tests and is declared a new monk of Shaolin, there will be a fight , as a part of the welcome party. Every monk has an unique id and a unique fighting grade, which are all integers. The new monk must fight with a old monk whose fighting grade is closest to his fighting grade. If there are two old monks satisfying that condition, the new monk will take the one whose fighting grade is less than his.
The master is the first monk in Shaolin, his id is 1,and his fighting grade is 1,000,000,000.He just lost the fighting records. But he still remembers who joined Shaolin earlier, who joined later. Please recover the fighting records for him.
 

Input
There are several test cases.
In each test case:
The first line is a integer n (0 <n <=100,000),meaning the number of monks who joined Shaolin after the master did.(The master is not included).Then n lines follow. Each line has two integer k and g, meaning a monk's id and his fighting grade.( 0<= k ,g<=5,000,000)
The monks are listed by ascending order of jointing time.In other words, monks who joined Shaolin earlier come first.
The input ends with n = 0.
 

Output
A fight can be described as two ids of the monks who make that fight. For each test case, output all fights by the ascending order of happening time. Each fight in a line. For each fight, print the new monk's id first ,then the old monk's id.
 

Sample Input
  
  
3 2 1 3 3 4 2 0
 

Sample Output
  
  
2 1 3 2 4 2

题意:题目有第1个和尚的战斗力,再给你n个逐个入寺的和尚的id(就是名字一样的)和战斗力,叫你求出每一个新来和尚要和哪个在他之前来的战斗力较接近的和尚战斗。

方法一:

AC代码(暴力):

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define maxn 100050
#define max 1000000000
using namespace std;
//author:YangSir
//time:2014/6/23
struct node{
	int k,g,n;
}q[maxn],w[maxn];

bool cmp(node a,node b){
	return a.g<b.g;
}

int main(){
	int n,i,j,f1,f2,x,a,b;
	while(~scanf("%d",&n),n){
		for(i=0;i<n;i++){
			scanf("%d%d",&q[i].k,&q[i].g);
			q[i].n=i+1;
		}
		sort(q,q+n,cmp);
		q[n].k=1;
		q[n].g=max;
		q[n].n=0;
		for(i=0;i<n;i++){//二分查找,找战斗力相邻的比他早当和尚的
			f1=f2=0;
			for(x=i-1;x>=0;x--){//往前找
				if(q[i].n>q[x].n){
					f1=1;
					break;
				}
			}
			for(j=i+1;j<n+1;j++){//往后找
				if(q[i].n>q[j].n){
					f2=1;
					break;
				}
			}//判断往前往后查找的情况
			if(f1&&f2){
				a=q[i].g-q[x].g;
				b=q[j].g-q[i].g;
				if(a<b||a==b){
					w[q[i].n].k=q[i].k;
					w[q[i].n].g=q[x].k;
				}
				else{
					w[q[i].n].k=q[i].k;
					w[q[i].n].g=q[j].k;
				}
			}
			else if(f1&&!f2){
				w[q[i].n].k=q[i].k;
				w[q[i].n].g=q[x].k;
			}
			else if(!f1&&f2){
				w[q[i].n].k=q[i].k;
				w[q[i].n].g=q[j].k;
			}
		}
		for(i=1;i<n+1;i++)
			printf("%d %d\n",w[i].k,w[i].g);
	}
	return 0;
}
方法二:

AC代码(STL的set应用):

#include <cstdio>
#include <cstring>
#include <iostream>
#include <set>
#include <algorithm>
#include <cmath>
#define maxn 100050
#define max 1000000000
using namespace std;
//author:YangSir
struct node{
	int id,g;
	bool operator < (const node& x) const{
		return g<x.g;
	}
}m[maxn];
set <node> s;
set <node>::iterator p;
int main(){
	int n,i,a,b;
	node q,w;
	while(~scanf("%d",&n),n){
		s.clear();
		m[0].id=1;
		m[0].g=max;
		s.insert(m[0]);
		for(i=0;i<n;i++){
			scanf("%d%d",&m[i].id,&m[i].g);
			p=s.lower_bound(m[i]);
			q=*p;
			if(s.size()>1){
				p--;
				w=*p;
				a=abs(q.g-m[i].g);//比较前后的差值大小
				b=abs(w.g-m[i].g);
				if(a<b)
					printf("%d %d\n",m[i].id,q.id);
				else
					printf("%d %d\n",m[i].id,w.id);
			}
			else
				printf("%d %d\n",m[i].id,q.id);
			s.insert(m[i]);
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值