NAT的3种实现方式配置示范

转载 2007年09月24日 11:35:00
 作者:懒虫    出处:懒虫's Blog

NAT包括有静态NAT、动态地址NAT和端口多路复用地址转换三种技术类型。静态 NAT是把内部网络中的每个主机地址永久映射成外部网络中的某个合法地址;动态地址NAT是采用把外部网络中的一系列合法地址使用动态分配的方法映射到内 部网络;端口多路复用地址转换是把内部地址映射到外部网络的一个IP地址的不同端口上。根据不同的需要,选择相应的NAT技术类型。

一般我们实际工作中都使用复用NAT,即复用断口NAT,也叫PNAT.

  所以掌握最后配置就可以了。

  静态NAT配置步骤:

  首先,配置各接口的IP地址。内网使用私有IP.外网使用公网IP.并指定其属于内外接口。

  其次,定义静态建立IP地址之间的静态映射。

  最后,指定其默认路由。

Router>en (进入特权模式)
Router#config (进入全局配置模式)
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ho R3 (命名为R3)
R3(config)#no ip domain-lo
(关闭域名查询,在实验环境中,敲入错误的命令,它将进行域名查询,故关闭他)
R3(config)#line c 0 (进入线路CONSOLE接口0下)
R3(config-line)#logg syn (启用光标跟随,防止日志信息冲断命令显示的位置)
R3(config-line)#exec-t 0 0 (防止超时,0 0 为永不超时)
R3(config-line)#exit
R3(config)#int e0 (进入以太网接口下)
R3(config-if)#ip add 192.168.1.1 255.255.255.0 (设置IP地址)
R3(config-if)#ip nat inside (设置为内部接口)
R3(config-if)#no shut
R3(config-if)#exit
R3(config)#int ser1 (进入串口下)
R3(config-if)#ip add 100.0.0.1 255.255.255.0
R3(config-if)#no shut
R3(config-if)#ip nat outside (设置为外部接口)
R3(config-if)#exit
R3(config)#ip nat inside source static 191.168.1.1 100.0.0.1
(设置静态转换,其中ip nat inside source 为NAT转换关键字,这里是静态,故为STATIC)
R3(config)#ip classless
R3(config)#ip route 0.0.0.0 0.0.0.0 s0(这里是出口或者下一跳地址)
R3(config)#exit
动态NAT配置步骤:

  首先,配置各需要转换的接口的IP,设置内外网IP等。

  其次,定义动态地址转换池列表

  再次,配置ACL列表,需要转换的内网IP地址(或者网段)。

  最后,设置转换后的出口地址段及MASK(多IP可以多分流,减轻转换后的负担)

  配置示例:

(一):
Router#config
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ho R2
R2(config)#no ip domain-lo
R2(config)#line c 0
R2(config-line)#logg syn
R2(config-line)#exec-t 0 0
R2(config-line)#exit
R2(config)#int ser0
R2(config-if)#ip add 100.0.0.1 255.255.255.0
R2(config-if)#ip nat inside
R2(config-if)#no shut
R2(config-if)#clock rate 5600
R2(config-if)#ip access-group 1 out
R2(config-if)#exit
R2(config)#int e0
R2(config-if)#ip ad 10.0.0.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
(二):
R2(config)#ip nat inside source list 1 pool dongsheng
(三):
R2(config)#access-list 1 permit 10.0.0.1 0.0.0.0
R2(config)#access-list 1 permit 10.0.0.2 0.0.0.0
(四):
R2(config)#ip nat pool dongsheng 100.0.0.1 100.0.0.2 netmask 255.255.255.0
R2(config)#exit

 

 动态NAT配置

ip nat inside source list 1 pool dongsheng
access-list 1 permit 10.0.0.1 0.0.0.0(与下面的公网IP对应)
access-list 1 permit 10.0.0.2 0.0.0.0
ip nat pool dongsheng 192.16.1.1 192.16.1.2 netmask 255.255.255.0
注:(一段IP地址范围,动态NAT与静态NAT一样,都是一对一的关系,
如果上面内网是3个IP,则下面也需要3个公网IP,如何设置2个出口呢?在2个串口上设置?)
!
interface Ethernet0
ip address 10.1.1.1 255.255.255.0
ip nat inside
no shut
!
interface Serial0
ip address 192.16.1.1 255.255.255.0
ip nat outside
no shut
!

  动态配置示例

Router#config
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ho R2
R2(config)#no ip domain-lo
R2(config)#line c 0
R2(config-line)#logg syn
R2(config-line)#exec-t 0 0
R2(config-line)#exit
Router(config)#int ser0
Router(config-if)#ip add 100.1.1.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#ip nat outside
Router(config-if)#exi
Router(config)#int e0
Router(config-if)#ip add 192.168.2.1 255.255.255.0
Router(config-if)#ip nat inside
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#ip nat inside source list 2 pool ds2 overload
(跟前面一样,这里设置复用动态转换,跟动态一个区别就是这里多增加了一个OVERLOAD)
Router(config)#access-list 2 permit 192.168.2.1 0.0.0.0
Router(config)#access-list 2 permit 192.168.2.2 0.0.0.0
Router(config)#ip nat pool ds2 100.1.1.1 100.1.1.2 net 255.255.255.0
Router(config)#exi
Router#sh run

  PAT配置示例

Router>en
Router#config
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int ser1
Router(config-if)#exit
Router(config)#no ip domain-lo
Router(config)#line c 0
Router(config-line)#logg syn
Router(config-line)#exec-t 0 0
Router(config-line)#exit
Router(config)#int ser1
Router(config-if)#ip add 100.0.0.1 255.255.255.0
Router(config-if)#ip nat outside
Router(config-if)#ip access-group 1 out
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int e0
Router(config-if)#ip add 192.168.1.1 255.255.255.0
Router(config-if)#ip nat inside
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#ip nat inside source list 1 pool ds1 overload
(其中ip nat inside source list X pool xx overload为关键字)
Router(config)#access-list 1 permit 192.168.0.1 255.255.0.0
(设置访问列表,允许内部的网络转换出去,网段自由设顶)
Router(config)#ip nat pool ds1 100.0.0.1 100.0.0.2 netmask 255.255.255.0
(这里的IP为能在公网上使用的IP,这里设置了2个IP,可以为几个,
如果后面设置为10。0。0。5,那么这里就有5个公网IP,一般2个就够了)
Router(config)#exit

华为Basic NAT和NAPT实现原理

NAT是路由器的一项非常重要,且应用非常广泛的技术,但许多读者对NAT的各种实现方式的工作原理一直没有搞清楚,其实很简单。本篇先介绍两种NAT实现方式的工作原理,下篇再介绍另两种实现方式的工作原理。...
  • lycb_gz
  • lycb_gz
  • 2014年09月09日 08:20
  • 7491

linux 使用NAT上网共享方式设置参考

2011-11-02 08:39 VMware下linux Ubuntu10.04使用NAT共享主机IP上网方式的设置参考 VMware虚拟机安装后,在“网上邻居”-“查看网络链接”里会...
  • yingqiangli
  • yingqiangli
  • 2013年05月10日 11:27
  • 819

虚拟机的linux系统设置NAT方式上网

虚拟机linux上网配置 图解教程 2009-07-08 17:59 虚拟机linux NAT方式上网图文详解 虚拟机linux下NAT上网方式跟wi...
  • zhubosa
  • zhubosa
  • 2013年05月23日 13:47
  • 1962

网络基本功(十九):细说NAT原理与配置

网络基本功(十九):细说NAT原理与配置   转载请在文首保留原文出处:EMC中文支持论坛https://community.emc.com/go/chinese      介绍 ...
  • mxway
  • mxway
  • 2015年03月14日 18:03
  • 2859

Ubuntu下设置通过NAT方式上网(静态IP)

背景 在虚拟机下运行操作系统,尤其是Linux系统已经是非常常见的做法。有时你想在虚拟机下搭建一个(模拟)服务器来供主机访问,比如搭建一个telnet/ssh。此时你会发现,每次启动虚拟机,VMWa...
  • jipingyuan
  • jipingyuan
  • 2014年08月01日 19:39
  • 8656

Linux_CentOS_NAT上网方式_最简单的上网模式,几乎不需要什么设置

Linux的连网模式有三种,Bridge、NAT和host-only。三种f
  • u013080459
  • u013080459
  • 2014年05月16日 09:56
  • 4472

NAT原理与NAT穿透

NAT原理      网络地址转换(NAT,Network Address Translation)属接入广域网(WAN)技术,是一种将私有(保留)地址转化为合法IP地址的转换技术。下面介绍两类不...
  • byxdaz
  • byxdaz
  • 2016年10月11日 10:45
  • 6989

ajax的三种实现方式

Jquery的ajax实现 load方法 1 实现load方法中只有url参数的效果 load(url)     2 load方法中带三个参数 url data  function   第一个...
  • z_zhangteng_t
  • z_zhangteng_t
  • 2016年11月20日 11:11
  • 1271

html5 localStorage实现表单本地存储

进入正题了,项目中有许多表单输入框要填写,还有一些单选复选框之类的.用户可能在填写了大量的信息之后,不小心刷新了页面或者出现了什么异常,导致页面上填写的信息消失了.还得重新填写信息,麻烦至极.   ...
  • fanhu6816
  • fanhu6816
  • 2016年10月08日 16:42
  • 1048

虚拟机中centos7实现nat静态ip上网

1.设置虚拟机网卡VMnet8 如图,我设置的ip为192.168.80.1,设置完毕后保存。 2.修改虚拟机参数 (1).点击编辑-->虚拟网络编辑器,如下图设置 (2)nat设置如...
  • dmyccc
  • dmyccc
  • 2015年07月30日 20:57
  • 976
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:NAT的3种实现方式配置示范
举报原因:
原因补充:

(最多只允许输入30个字)