POJ 3617 Best Cow Line [贪心] 《挑战程序设计竞赛》2.2

竞赛题目链接

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual”Farmer of the Year” competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows’ names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he’s finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

Line 1: A single integer: N
Lines 2..N+1: Line i+1 contains a single initial (‘A’..’Z’) of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows (‘A’..’Z’) in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

Source

USACO 2007 November Silver

题目大意:

给定长度为N的字符串S, 要构造一个长度为N的字符串T.起初,T是一个空字符串,随后反复进行下列任意操作:
1.从S的头部删除一个字符,加到T的尾部
2.从S的尾部删除一个字符,加到T的尾部
目标是要构造字典序尽可能小的字符串T.

题解:

每次选取头部或者尾部较小的字符.
如果头尾字符相等,不能随便选择,需要选择下一个位置较小的那个. 比如CDBC, 应选择尾部的C,这样就可以尽早的使用B,而不是D.
如果下一个位置也相等,则以此类推.

需要注意的是, 题目要求一行只能有80个字符.由于英语不好粗心Presentation Error了好几次…

代码:

#include <iostream>
#include <cstdio>
#include <string>
#define MAX_N 2010
using namespace std;

int N;
char S[MAX_N];
void solve() {
    int a = 0, b = N-1;
    int cnt = 0;
    while (a <= b) {
        bool left = false;
        for (int i = 0; a + i < b; i++) {
            if (S[a+i] < S[b-i]) {
            left = true;
            break;
            } 
            else if (S[a+i] > S[b-i]) {
            left = false;
            break;
            }
        }
        if (left) putchar(S[a++]);
        else putchar(S[b--]);
        if (!(++cnt % 80)) putchar('\n');
    }
    putchar('\n');
}

int main() {
    cin >> N;
    for (int i = 0; i < N; i++) 
    cin >> S[i];
    solve();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值