杭电1131

                              Word Amalgamation

                                      Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                        Total Submission(s): 1445    Accepted Submission(s): 665


Problem Description
In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.

Input
The input contains four parts:

1. a dictionary, which consists of at least one and at most 100 words, one per line;
2. a line containing XXXXXX, which signals the end of the dictionary;
3. one or more scrambled `words' that you must unscramble, each on a line by itself; and
4. another line containing XXXXXX, which signals the end of the file.

All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.

Output
For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line ``NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.

Sample Input
  
  
tarp given score refund only trap work earn course pepper part XXXXXX resco nfudre aptr sett oresuc XXXXXX

Sample Output
  
  
score ****** refund ****** part tarp trap ****** NOT A VALID WORD ****** course ******

Source

Recommend
Eddy
#include <stdio.h>
#include <string.h>
int main()
{
	int i,j,n,l1,l2,x,y,k;
	char s1[100][10],s2[100][10],s3[10],s4[]={"XXXXXX"},s5[10];
	int a[10];
	i=0;
	while(scanf("%s",s3)!=EOF)
	{
		if(strcmp(s3,s4)==0)
		{
			break;
		}
		strcpy(s1[i],s3);
		i+=1;
	}
	n=i;
	while(scanf("%s",s3)!=EOF)
	{
		
		y=0;
		if(strcmp(s3,s4)==0)
		{
			break;
		}
		l1=strlen(s3);
		for(i=0;i<=n-1;i++)
		{
			for(j=0;j<=9;j++)
			{
			 a[j]=1;
			}
			l2=strlen(s1[i]);
			if(l2==l1)
			{
				for(j=0;j<=l1-1;j++)
				{
					for(x=0;x<=l1-1;x++)
					{
						if(s3[j]==s1[i][x]&&a[x]==1)
						{
							a[x]=0;
							break;
						}
					}
					if(x==l1)
					{
						break;
					}
				}
				if(j==l1)
				{
					strcpy(s2[y],s1[i]);
					y+=1;
				}
			}
		}
		if(y==0)
		{
			printf("NOT A VALID WORD\n");
		}else
		{
			for(i=0;i<=y-2;i++)
			{
				k=i;
				for(j=i+1;j<=y-1;j++)
				{
					if(strcmp(s2[k],s2[j])>0)
					{
						k=j;
					}
				}
				if(k!=i)
				{
					strcpy(s5,s2[i]);
					strcpy(s2[i],s2[k]);
					strcpy(s2[k],s5);
				}
			}
			for(i=0;i<=y-1;i++)
			{
				printf("%s\n",s2[i]);
			}
		}
		printf("******\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值