UVa 408 - Uniform Generator

 Uniform Generator 

Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

displaymath29

where `` tex2html_wrap_inline31 " is the modulus operator.

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the sameseed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 andMOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

Input

Each line of input will contain a pair of integers for STEP and MOD in that order ( tex2html_wrap_inline77 ).

Output

For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either ``Good Choice" or ``Bad Choice" left-justified starting in column 25. The ``Good Choice" message should be printed when the selection of STEP andMOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message ``Bad Choice". After each output test set, your program should print exactly one blank line.

Sample Input

3 5
15 20
63923 99999

Sample Output

         3         5    Good Choice

        15        20    Bad Choice

     63923     99999    Good Choice
  看到网上说 这道题目就是求最大公约数,公约数为1,就为Good  否则则为Bad,但是没有给出解释,我将做出解释,其实是这样的。假设 step和 mod有最大公约数 k   (k>1),如果是step>mod 那么在第一次计算的时候,会step%mod=0,从而这个组永远就是0,显然与题意不符,如果是step<mod,第一次计算的时候结果为step本身,第二次为2*step,第三次是3*step,一直到(k-1)*step,此时下一次计算就为 (k*step)%mod=0,  得不到题意的要求。 因此只能是最大公约数为1
#include <stdio.h>
#include <string.h>
#include <math.h>
int main()
{
    int gcd(int a,int b);
    int i,j,n,m,s,t;
    int a,b;
    while(scanf("%d %d",&a,&b)!=EOF)
    {
        t=gcd(a,b);
        printf("%10d%10d    ",a,b);
        if(t==1)
        {
            printf("Good Choice\n");
        }else
        {
            printf("Bad Choice\n");
        }
        printf("\n");
    }
    return 0;
}
int gcd(int a,int b)
{
    return b? gcd(b,a%b):a;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值