[poj2104]K-th Number 主席树

K-th Number
Time Limit: 20000MS Memory Limit: 65536K
Total Submissions:  Accepted: 
Case Time Limit: 2000MS

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 10 9 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

还在A这道题说明我连主席树这么low的之前都不会
1.转化为两棵可以相减的线段树
2.每次修改为一条链
代码解释
#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int N = 100000+5;
int root[N],ls[N*20],rs[N*20],v[N*20]/*主席树系列*/,val[N],p[N],n,m,rank[N],id,ans;
bool cmp( int a, int b ){ return val[a] < val[b]; }
void build( int &k, int l, int r, int x ){
	ls[++id] = ls[k]; rs[id] = rs[k]; v[id] = v[k]+1; k = id;//继承上一棵树的信息 
	if( l == r ) return ;
	int mid = (l+r)>>1;
	if( x <= mid ) build( ls[k], l, mid, x );
	else build( rs[k], mid+1, r, x );
}
int query( int a, int b, int l, int r, int k ){
	if( l == r ) return l; int mid = (l+r)>>1;
	int t = v[ls[b]]-v[ls[a]];
	if( t >= k ) return query( ls[a], ls[b], l, mid, k );
	else return query( rs[a], rs[b], mid+1, r, k-t );
}
int main(){
	scanf("%d%d", &n, &m);
	for( int i = 1; i <= n; i++ ) scanf("%d", &val[i]), p[i] = i;
	std::sort(p+1,p+n+1,cmp);
	for( int i = 1; i <= n; i++ ) rank[p[i]] = i;//离散化 (原始数据对答案无用,会MLE) 
	for( int i = 1; i <= n; i++ ){
		root[i] = root[i-1];
		build(root[i],1,n,rank[i]);//建一棵主席树 
	}
    for( int i = 1,x,y,z; i <= m; i++ ){
        scanf("%d%d%d", &x, &y, &z);
        ans = query( root[x-1], root[y], 1, n, z );
        printf("%d\n", val[p[ans]]);
    }
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值