poj 2528 Mayor's posters

Language:

Mayor's posters

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 55255 Accepted: 16024

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
  • Every candidate can place exactly one poster on the wall.
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
  • The wall is divided into segments and the width of each segment is one byte.
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall.

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

Source



注:n虽然小于等于10000,但每组有两个数字,最坏就是2*n,离散化时候,最坏插入2*n个点,一共4*n个点,建树要4*4*n个点才行


code:

#include <set>
#include <map>
#include <list>
#include <cmath>
#include <ctime>
#include <deque>
#include <queue>
#include <stack>
#include <cctype>
#include <cstdio>
#include <string>
#include <vector>
#include <cassert>
#include <cstdlib>
#include <cstring>
#include <sstream>
#include <iostream>
#include <algorithm>
#define pi acos(-1.0)
#define maxn (10000 + 10)
using namespace std;
typedef long long int LLI;

struct node {
    int Left;
    int Right;
} op[maxn * 6];

struct Tree {
    int Left;
    int Right;
    int Col;
} tree[20 * maxn];

int xcnt = 1,x[maxn * 6],txcnt = 1,cnt = 0;
bool isappear[maxn * 6];

void Build_tree(int l,int r,int p) {
    tree[p].Col = 0;
    tree[p].Left = l;
    tree[p].Right = r;
    if(l != r) {
        int mid = (l + r) >> 1;
        Build_tree(l,mid,(p << 1));
        Build_tree(mid + 1,r,(p << 1) + 1);
    }
}

void Update(int l,int r,int col,int p) {
    if(tree[p].Col == col)  return;
    if(tree[p].Left == l && tree[p].Right == r) {
        tree[p].Col = col;
        return;
    }
    if(tree[p].Col != -1) {
        tree[(p << 1)].Col = tree[(p << 1) + 1].Col = tree[p].Col;
        tree[p].Col = -1;
    }
    int mid = (tree[p].Left + tree[p].Right) / 2;
    if(mid >= r)            Update(l,r,col,(p << 1));
    else if(mid + 1 <= l)   Update(l,r,col,(p << 1) + 1);
    else {
        Update(l,mid,col,(p << 1));
        Update(mid + 1,r,col,(p << 1) + 1);
    }
}

void Query(int p) {
    if(tree[p].Col >= 1) {
        if(!isappear[tree[p].Col]) {
            cnt ++;
            isappear[tree[p].Col] = true;
            return;
        } else    return;
    } else if(tree[p].Col == 0)   return;
    Query(p << 1);
    Query((p << 1) + 1);
}

int main() {
//    freopen("in.txt", "r", stdin);
//    freopen("out.txt", "w", stdout);
    int t;
    scanf("%d",&t);
    for(int Case = 1; Case <= t; Case ++) {
        int n;
        xcnt = 1;
        cnt = 0;
        scanf("%d",&n);
        memset(isappear,false,sizeof(isappear));
        for(int i = 1; i <= n; i ++) {
            scanf("%d%d",&op[i].Left,&op[i].Right);
            x[xcnt ++] = op[i].Left;
            x[xcnt ++] = op[i].Right;
        }
        sort(x + 1,x + xcnt);
        txcnt = xcnt;
        xcnt = 2;
        for(int i = 2; i < txcnt; i ++) {
            if(x[i] != x[i - 1])    x[xcnt ++] = x[i];
        }
        for(int i = xcnt - 1; i >= 2; i --) {
            if(x[i] - x[i - 1] > 1)     x[xcnt ++] = x[i] - 1;
        }
        sort(x + 1,x + xcnt);
        Build_tree(1,xcnt - 1,1);
        for(int i = 1; i <= n; i ++) {
            int l = lower_bound(x + 1,x + xcnt,op[i].Left) - x;
            int r = lower_bound(x + 1,x + xcnt,op[i].Right) - x;
            Update(l,r,i,1);
        }
        Query(1);
        printf("%d\n",cnt);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值