POJ 题目1861 Network(最小生成树)

Network
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 14062 Accepted: 5515 Special Judge

Description

Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs). 
Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections. 
You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied. 

Input

The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 10 6. There will be no more than one way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.

Output

Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.

Sample Input

4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

Sample Output

1
4
1 2
1 3
2 3
3 4

Source

Northeastern Europe 2001, Northern Subregion
ac代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct s
{
	int x,y,w;
}edge[100010],ans[100010];
int cmp(const void *a,const void *b)
{
	return (*(struct s *)a).w-(*(struct s *)b).w;
}
int n,m;
int pre[100010];
void init()
{
	for(int i=0;i<=n;i++)
	{
		pre[i]=i;
	}
}
int find(int x)
{
	if(x==pre[x])
		return x;
	return pre[x]=find(pre[x]);
}
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		int i,j,k;
		init();
		for(i=0;i<m;i++)
		{
			scanf("%d%d%d",&edge[i].x,&edge[i].y,&edge[i].w);
		}
		qsort(edge,m,sizeof(edge[0]),cmp);
		int cnt=0,maxn=-1,sum=0;
		for(i=0;i<m;i++)
		{
			int fx=find(edge[i].x);
			int fy=find(edge[i].y);
			if(fx!=fy)
			{
				sum+=edge[i].w;
				pre[fx]=fy;
				ans[cnt].x=edge[i].x;
				ans[cnt++].y=edge[i].y;
				if(edge[i].w>maxn)
					maxn=edge[i].w;
			}
		}
		printf("%d\n%d\n",maxn,cnt);
		for(i=0;i<cnt;i++)
		{
			printf("%d %d\n",ans[i].x,ans[i].y);
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值