HDOJ 题目5154 Harry and Magical Computer(拓扑排序)

Harry and Magical Computer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1046    Accepted Submission(s): 424


Problem Description
In reward of being yearly outstanding magic student, Harry gets a magical computer. When the computer begins to deal with a process, it will work until the ending of the processes. One day the computer got n processes to deal with. We number the processes from 1 to n. However there are some dependencies between some processes. When there exists a dependencies (a, b), it means process b must be finished before process a. By knowing all the m dependencies, Harry wants to know if the computer can finish all the n processes.
 

Input
There are several test cases, you should process to the end of file.
For each test case, there are two numbers n m on the first line, indicates the number processes and the number of dependencies.  1n100,1m10000
The next following m lines, each line contains two numbers a b, indicates a dependencies (a, b).  1a,bn
 

Output
Output one line for each test case. 
If the computer can finish all the process print "YES" (Without quotes).
Else print "NO" (Without quotes).
 

Sample Input
  
  
3 2 3 1 2 1 3 3 3 2 2 1 1 3
 

Sample Output
  
  
YES NO
 

Source
 

Recommend
heyang   |   We have carefully selected several similar problems for you:   5185  5184  5183  5182  5181 
 
ac代码
#include<stdio.h>
#include<string.h>
int n,m;
int dig[1010],map[1010][1010];
int topu()
{
	int i,j;
	for(i=1;i<=n;i++)
	{
		int u=-1;
		for(j=1;j<=n;j++)
		{
			if(dig[j]==0)
			{
				dig[j]--;
				u=j;
				break;
			}
		}
		if(u==-1)
			return 0;
		for(j=1;j<=n;j++)
		{
			if(map[u][j])
			{
				dig[j]--;
				map[u][j]=0;
			}
		}
	}
	return 1;
}
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		int i;
		memset(map,0,sizeof(map));
		memset(dig,0,sizeof(dig));
		for(i=0;i<m;i++)
		{
			int u,v;
			scanf("%d%d",&u,&v);
			if(!map[u][v])
			{
				map[u][v]=1;
				dig[v]++;
			}
		}
		if(topu())
		{
			printf("YES\n");
		}
		else
			printf("NO\n");
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值