POJ 题目3692 Kindergarten(最大独立集)

Kindergarten
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5710 Accepted: 2776

Description

In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.

Input

The input consists of multiple test cases. Each test case starts with a line containing three integers
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ MG × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.

The last test case is followed by a line containing three zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.

Sample Input

2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0

Sample Output

Case 1: 3
Case 2: 4

Source

题目大意:幼儿园有g个女孩和b个男孩,同性之间互相认识,而且男孩和女孩之间有的也互相认识。现在要选出来最多的孩子,他们之间都互相认识。

   一道基础的二分图最大独立集问题。

ac代码
#include<stdio.h>
#include<string.h>
int link[220],map[220][220],vis[220];
int x,y,m;
void init()
{
	int i,j;
	for(i=0;i<=x;i++)
	{
		for(j=0;j<=y;j++)
			map[i][j]=1;
	}
}
int dfs(int x)
{
	int i;
	for(i=1;i<=y;i++)
	{
		if(!vis[i]&&map[x][i])
		{
			vis[i]=1;
			if(link[i]==-1||dfs(link[i]))
			{
				link[i]=x;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int c=0;
	while(scanf("%d%d%d",&x,&y,&m)!=EOF,x||m||y)
	{
		int i;
		init();
		while(m--)
		{
			int a,b;
			scanf("%d%d",&a,&b);
			map[a][b]=0;
		}
		memset(link,-1,sizeof(link));
		int ans=0;
		for(i=1;i<=x;i++)
		{
			memset(vis,0,sizeof(vis));
			if(dfs(i))
				ans++;
		}
		printf("Case %d: %d\n",++c,x+y-ans);
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值