UVA 题目10401 Injured Queen Problem(DP)

Chess is a two-player board game believed
to have been played in India as early as
the sixth century. However, in this problem
we will not discuss about chess, rather
we will talk about a modified form of the
classic n- queens problem. I know you are
familiar with plotting n-queens on a chess
board with the help of a classic backtracking
algorithm. If you write that algorithm
now you will find that there are 92 ways
of plotting 8 queens in an 8 × 8 board
provided no queens attack each other.
In this problem we will talk about injured
queens who can move only like a
king in horizontal and diagonal direction
from current position but can reach any
row from current position like a normal chess queen. You will have to find the number of possible arrangements
with such injured queens in a particular (n × n) board (with some additional constraints),
such that no two queens attack each other.
Fig: Injured Queen at a6 can reach the adjacent grey squares. Queen at e4 can reach adjacent grey
squares. The injured queen positions are black and the reachable places are grey.
Input
Input file contains several lines of input. Each line expresses a certain board status. The length of these
status string is the board dimension n (0 < n ≤ 15). The first character of the string denotes the status
of first column, the second character of the string denotes the status of the second column and so on.
So if the first character of the status string is 2, it means that we are looking for arrangements (no two
injured queen attack each other) which has injured queen in column a, row 2. The possible numbers
for rows are 1, 2, 3, . . . , D, E, F which indicates row 1, 2, 3... 13, 14, 15. If any column contains ‘?’
it means that in that column the injured queen can be in any row. So a status string ‘1?4??3 means
that you are asked to find out total number of possible arrangements in a (6 × 6) chessboard which
has three of its six injured queens at a1, c4 and f3. Also note that there will be no invalid inputs. For
example ‘1?51’ is an invalid input because a (4 × 4) chessboard does not have a fifth row.
Output
For each line of input produce one line of output. This line should contain an integer which indicates
the total number of possible arrangements of the corresponding input status string.
Sample Input
??????
???????????????
???8?????
43?????
Sample Output
2642
22696209911206174
2098208

0

题目大意:给出一个字符串,要求在n * n(n为字符串的长度)的棋盘上摆放n个受伤的皇后,受伤的皇后只能攻击到同一列和它周围8个格子,如果字符串中第i个字符为'?'表示第i + 1个皇后可以摆放在任意行,如果为1 ~ F表示第i+1个皇后必须摆放在第str[i]行, 问,有多少种不同的摆法?

dp[i][j] = dp[i - 1][k] ( 0 < k < n && abs (j - k) > 1)。

ac代码

16448388 10401 Injured Queen Problem Accepted C++ 0.006 2015-11-17 04:43:30
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define LL long long
using namespace std;
char str[22];
LL dp[22][22];
int fun(char s)
{
    if(s>='1'&&s<='9')
    {
        return s-'1';
    }
    return s-'A'+9;
}
void DP()
{
    int i,j,k;
    memset(dp,0,sizeof(dp));
    int len=strlen(str);
        if(str[0]=='?')
        {
            for(j=0;j<len;j++)
            {
                dp[0][j]=1;
            }
        }
        else
        {
            int c=fun(str[0]);
            dp[0][c]=1;
        }
    for(i=1;i<len;i++)
    {
        if(str[i]=='?')
        {
            for(j=0;j<len;j++)
            {
                for(k=0;k<j-1;k++)
                    dp[i][j]+=dp[i-1][k];
                for(k=j+2;k<len;k++)
                    dp[i][j]+=dp[i-1][k];
            }
        }
        else
        {
            j=fun(str[i]);
            for(k=0;k<j-1;k++)
                dp[i][j]+=dp[i-1][k];
            for(k=j+2;k<len;k++)
                dp[i][j]+=dp[i-1][k];
        }
    }
}
int main()
{
    while(scanf("%s",str)!=EOF)
    {
        int i;
        DP();
        LL ans=0;
        int len=strlen(str);
        for(i=0;i<len;i++)
            ans+=dp[len-1][i];
        printf("%lld\n",ans);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
YOLO高分设计资源源码,详情请查看资源内容中使用说明 YOLO高分设计资源源码,详情请查看资源内容中使用说明 YOLO高分设计资源源码,详情请查看资源内容中使用说明 YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值