深搜 hdu —— 1010

Tempter of the Bone

Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
      
      
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
      
      
NO YES

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1010

用深搜+剪枝

剪枝1:超界返回

剪枝2:判断 剩余时间=总时间-已用时间-此时距门的距离  是否为负,或是否为奇数,则返回

剪枝3:刚好到达则返回


#include<stdio.h>
#include<math.h>
#include<iostream>
#include<algorithm>
using namespace std;
int n,m,kk,p;
int sx,sy,ex,ey;
char map[10][10];
const int c[4][2]={1,0,-1,0,0,1,0,-1};
void dfs(int x,int y,int num){
	int dd,kx,ky;
	if(x<=0 || y<=0 || x>n || y>m)	return ;
	if(x==ex && y==ey && kk==num){
		p=1;
		return ;
	}
	
	dd=kk-num-abs(x-ex)-abs(y-ey);
	if(dd<0 || dd%2)	return ;
	for(int i=0;i<4;i++){
		kx=x+c[i][0];
		ky=y+c[i][1];
		if(map[kx][ky]!='X'){
			map[kx][ky]='X';
			dfs(kx,ky,num+1);
			map[kx][ky]='.';
			if(p)	return ;
		}
	}
	return ;
}

int main()
{
	while(~scanf("%d%d%d",&n,&m,&kk)){
		if(n==0 && m==0 && kk==0)	break;
		for(int i=1;i<=n;i++){
			for(int j=1;j<=m;j++){
				cin>>map[i][j];
				if(map[i][j]=='S'){
					sx=i;
					sy=j;
				}
				if(map[i][j]=='D'){
					ex=i;
					ey=j;
				}
			}
		}
		p=0;
		map[sx][sy]='X';
		dfs(sx,sy,0);
		if(p)	cout<<"YES"<<endl;
		else	cout<<"NO"<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

黎轩栀海

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值