uva315

A - Network
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N. No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0.

Output

The output contains for each block except the last in the input file one line containing the number of critical places.

Sample Input

5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0

Sample Output

1
2
题意:给一个数n,接下来最多n行,每行第一个数a,然后又有一些个数bi,表示a-bi之间有一条无向边,
如果a==0,这组样例结束,如果n==0,数据输入结束,最后输出该图的割点个数,套模板;
代码:
#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>

using namespace std;
const int maxn=100010,maxm=100010;
struct Edge
{
    int to,next;
    bool cut;///标记是否为桥
}edge[maxm];
int head[maxn],tot;
int low[maxn],dfn[maxn],Stack[maxn];
int Index,top;
bool Instack[maxn],cut[maxn];
int add_block[maxn];///删除一个点以后正价的连通块
int bridge;
void init()
{
    tot=0;
    memset(head,-1,sizeof(head));
}
void add(int u,int v)
{
    edge[tot].to=v;
    edge[tot].next=head[u];
    edge[tot].cut=false;
    head[u]=tot++;
}
void Tarjan(int u,int pre)
{
    int v;
    low[u]=dfn[u]=++Index;
    Stack[top++]=u;
    Instack[u]=true;
    int son=0;
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        v=edge[i].to;
        if(v==pre)continue;
        if(!dfn[v])
        {
            son++;
            Tarjan(v,u);
            if(low[u]>low[v])low[u]=low[v];
            ///桥,
            ///一条边(u,v)是桥,当且仅当(u,v)为树枝边,且满足dfn[u]<low[v]
            if(low[u]>dfn[u])
            {
                bridge++;
                edge[i].cut=true;
                edge[i^1].cut=true;
            }
            ///割点
            ///一个顶点u是割点,当且仅当满足(1)或(2),(1)为树根,且u有多于一个子树
            ///(2)u不为树根,且满足存在(u,v)为树枝边
            ///(或称父子边)即u为v在搜索数中的父亲使得dfn[u]<=low[v]
            if(u!=pre&&low[v]>=dfn[u])
            {
                cut[u]=true;
                add_block[u]++;
            }

        }
        else if(low[u]>dfn[v])
        low[u]=dfn[v];
    }
    if(u==pre&&son>1)cut[u]=true;
    if(u==pre)add_block[u]=son-1;
    Instack[u]=false;
    top--;
}
int solve(int N)
{
    int ans=0;
    memset(dfn,0,sizeof(dfn));
    memset(Instack,0,sizeof(Instack));
    memset(add_block,0,sizeof(add_block));
    memset(cut,false,sizeof(cut));
    Index=0;
    bridge=0;
    for(int i=1;i<=N;i++)
        if(!dfn[i])
        Tarjan(i,i);
    for(int i=1;i<=N;i++)
        if(cut[i])
        ans++;
    return ans;
}
int main()
{
    int n;
    while(~scanf("%d",&n),n)
    {
        init();
        int a,b;
        char c;
        while(~scanf("%d",&a),a)
        {
            while(~scanf("%d%c",&b,&c))
            {
                add(a,b);
                add(b,a);
               if(c=='\n')break;
            }
        }
        printf("%d\n",solve(n));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值