POJ3292_Semi-prime H-numbers_变型素数筛&&二分求个数

Semi-prime H-numbers
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9572 Accepted: 4260

Description

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.

As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.

Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

Sample Input

21 
85
789
0

Sample Output

21 0
85 5
789 62

定义H数为模 4 余 1 的数。 H素数为在H数的范围内不含有 1 和它本身之外的其他因数的数。 H 半素数为最多只能由两个H素数相乘得到的 H 数,这两个 H 素数可能相同, 可能不同, 一个 H 半素数可以表示成多种 两H素数相乘。对于输入的 x, 求 1 到  x 之间 H 半素数的个数。


首先模拟筛法求素数打一个 H 素数表, 再打一个 H 半素数表。 最后对于每一个 x 询问二分求个数。


#include<cstdio>
#include<iostream>
#include<algorithm>

using namespace std;

const int maxn = 1000010;
int Hprime[maxn];//H 素数
int tot;//H 素数的个数
int hsp[maxn];//H 半素数
int tot1;//H 半素数的个数
bool vis[maxn];//H 半素数已经在 hsp 中存在的标记

//打表
void GetTab()
{
	//求 H 素数
	for(int i= 5; i< maxn; i+= 4) //只在 H 数中遍历
	{
		if(Hprime[i] == 0 ) Hprime[tot++] = i;

		for(int j= 0; j< tot && i*Hprime[j]< maxn; j++)
		{
			Hprime[i*Hprime[j]] = 1;
			if(i % Hprime[j] == 0) break;
		}
	}

	//求 H 半素数
	for(int i= 0; i< tot; i++)
		for(int j= 0; j<= i; j++)
		{
			int p = Hprime[i]*Hprime[j];

			if(p >= maxn) break;
			if(vis[p]) continue;//去重

			hsp[tot1++] = p;
			vis[p] = true;
		}

	sort(hsp, hsp+tot1);
}

int main ()
{
	GetTab();

	while(1)
	{
		int x;
		scanf("%d", &x);

		if(x == 0) break;

		//二分求个数
		int cnt = upper_bound(hsp, hsp+tot1, x) - hsp;

		printf("%d %d\n", x, cnt);
	}

	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值