POJ3468_A Simple Problem with Integers_树状数组区间和::区间修改

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 109152 Accepted: 33998
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

给一个含有 N 个元素的数组,再给 M 个操作。其中 M 个操作为求区间和或者区间元素统一加上一个数。


对于区间和询问操作,用树状数组维护每个元素的前缀和,用前缀和之差来表示区间和。

对于区间修改操作,有

i<l : s'(i) = s(i)

l <= i <= r : s'(i) = s(i) + x*(i-l-1) = s(i) + x*i - x*(l-1)

I>r : s'(i) = s(i) + x*(r-l-1) = s(i) + x*r - x*(l-1)

这时对区间的修改只需要对区间两端点操作就可以了,需要维护两个树状数组:

一个保存原数组,区间首的 -x(l-1) 和区间尾的 x*r, 这两项是与 i 无关的常数项

一个保存区间首的 x 和区间尾的 -x,这两项是与 i 有关的


具体分析见《挑战程序设计竞赛》181页。


树状数组的基本原理见《挑战程序设计竞赛》174页。


#include<cstdio>
#include<iostream>

using namespace std;
typedef long long LL;

const int maxn = 100000 + 10;
LL Bit[maxn];//第一个树状数组
LL Bit1[maxn];//第二个树状数组
int N, M;
char C;

//单点更改
void Add(LL *B, int p, int x)
{
	while(p <= N)
	{
		B[p] += x;
		p += p&-p;
	}
}

//求前缀和
LL Sum(LL *B, int p)
{
	LL res = 0;

	while(p)
	{
		res += B[p];
		p -= p&-p;
	}

	return res;
}

int main ()
{
	scanf("%d %d", &N, &M);

	for(int i= 1; i<= N; i++)
	{
		LL temp;
		scanf("%lld", &temp);

		Add(Bit, i, temp);
	}

	for(int k= 0; k< M; k++)
	{
		scanf(" %c", &C);

		if(C == 'C')
		{
			int l, r;
			LL x;
			scanf("%d %d %lld", &l, &r, &x);

			//对区间首尾的四项操作
			Add(Bit, l, -(l-1)*x);
			Add(Bit1, l, x);
			Add(Bit, r+1, x*r);
			Add(Bit1, r+1, -x);
		}

		else
		{
			int l, r;
			scanf("%d %d", &l, &r);

			//分别求前缀和再作差
			LL res = 0;
			res += Sum(Bit, r) + Sum(Bit1, r) * r;
			res -= Sum(Bit, l-1) + Sum(Bit1, l-1) * (l-1);

			printf("%lld\n", res);
		}

	}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
POJ 2182是一道使用树状数组解决的题目,题目要求对给定的n个数进行排序,并且输出每个数在排序后的相对位置。树状数组是一种用来高效处理前缀和问题的数据结构。 根据引用中的描述,我们可以通过遍历数组a,对于每个元素a[i],可以使用二分查找找到a到a[i-1]中小于a[i]的数的个数。这个个数就是它在排序后的相对位置。 代码中的query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。 最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。 参考代码如下: ```C++ #include <iostream> #include <cstdio> using namespace std; int n, a += y; } } int main() { scanf("%d", &n); f = 1; for (int i = 2; i <= n; i++) { scanf("%d", &a[i]); f[i = i & -i; } for (int i = n; i >= 1; i--) { int l = 1, r = n; while (l <= r) { int mid = (l + r) / 2; int k = query(mid - 1); if (a[i > k) { l = mid + 1; } else if (a[i < k) { r = mid - 1; } else { while (b[mid]) { mid++; } ans[i = mid; b[mid = true; add(mid, -1); break; } } } for (int i = 1; i <= n; i++) { printf("%d\n", ans[i]); } return 0; } ``` 这段代码使用了树状数组来完成题目要求的排序功能,其中query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *3* [poj2182Lost Cows——树状数组快速查找](https://blog.csdn.net/aodan5477/article/details/102045839)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] - *2* [poj_2182 线段树/树状数组](https://blog.csdn.net/weixin_34138139/article/details/86389799)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值