【Eclipse错误】Syntax error, parameterized types are only available if source level is 1.5

原创 2015年07月09日 09:52:11

导入一个Java项目报错Syntax error, parameterized types are only available if source level is 1.5

同时找不到swing下的JFrame;JPanel;

问题原因:编译器版本过低
解决方法:将编译器版本提高
eclipse-->"Windows"-->"preferneces"
在弹出对话框中 ,在左侧列表框中 选择 "JAVA" ---子菜单中 "compiler"
然后在右侧把 "Compiler compliance level" 设置成1.5及以上 即可。
版权声明:本文为博主原创文章,未经博主允许不得转载。

spring2.5.6的‘annotation-config’ and its parser class are only available on JDK 1.5 and higher错误解决

最近在学习马士兵的spring教程,视频教程中的项目中用的是spring低版本(2.5.6),今天用jre 8测试了一下,发现错误:  Unexpected exception parsing XM...

....are only available on JDK 1.5 and higher

Exception in thread "main" org.springframework.beans.factory.BeanDefinitionStoreException: Unexpecte...

AnnotationAwareAspectJAutoProxyCreator is only available on Java 1.5 and higher

异常 Exception sending context initialized event to listener instance of class org.springframework.w...

R--安装reshape 报错:Package which is only available in source form, and may need compilation of C/C++/Fo

对变量进行重命名(比如data.frame的列名称),有如下几种方法。 假设data.frame 的数据mydata如下: 有4列,想把后两列名称修改为weight1,weight2。方法1:调用...

error the @annotation pointcut expression is only supported at Java 5 compliance level or above 异常解决

1、异常信息严重: Exception sending context initialized event to listener instance of class or g.springframe...
  • p_3er
  • p_3er
  • 2015年05月15日 15:35
  • 3152

eclipse CDT debugger shows the wrong source file if filenames are the same

大家好,最近在linux下面,使用eclipse,遇到一个bug,这个bug不是我最早发现d

Genymotion出现unknown generic error和This may occur if you are using a proxy错误的解决方案

今天在实验室希望在Genymotion上多下载几个模拟器,需要重新登录帐号,却发现一个错误,叫做unknown generic error.前几天还出现过一个很诡异的问题。截图如下:...

解决nginx的An error occurred. The page you are looking for is temporarily unavailable错误办法

这篇文章写得超级棒 完美解决了问题   今天访问WordPress程序做的网站,突然出现The page you are looking for is temporarily unavailab...

ios提交市场报错误ERROR ITMS-9000: "this bundle is invalid. armv7s are required to include armv7 architectur

用Xcode提交市场的时候,报如下的错误: ERROR ITMS-9000: "this bundle is invalid. armv7s ...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:【Eclipse错误】Syntax error, parameterized types are only available if source level is 1.5
举报原因:
原因补充:

(最多只允许输入30个字)