DAG图上单源最短路径 poj 3249

Test for Job
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 7475 Accepted: 1634

Description

Mr.Dog was fired by his company. In order to support his family, he must find a new job as soon as possible. Nowadays, It's hard to have a job, since there are swelling numbers of the unemployed. So some companies often use hard tests for their recruitment.

The test is like this: starting from a source-city, you may pass through some directed roads to reach another city. Each time you reach a city, you can earn some profit or pay some fee, Let this process continue until you reach a target-city. The boss will compute the expense you spent for your trip and the profit you have just obtained. Finally, he will decide whether you can be hired.

In order to get the job, Mr.Dog managed to obtain the knowledge of the net profit Vi of all cities he may reach (a negative Vi indicates that money is spent rather than gained) and the connection between cities. A city with no roads leading to it is a source-city and a city with no roads leading to other cities is a target-city. The mission of Mr.Dog is to start from a source-city and choose a route leading to a target-city through which he can get the maximum profit.

Input

The input file includes several test cases.
The first line of each test case contains 2 integers n and m(1 ≤ n ≤ 100000, 0 ≤ m ≤ 1000000) indicating the number of cities and roads.
The next n lines each contain a single integer. The ith line describes the net profit of the city i, Vi (0 ≤ | Vi| ≤ 20000)
The next m lines each contain two integers x, y indicating that there is a road leads from city x to city y. It is guaranteed that each road appears exactly once, and there is no way to return to a previous city.

Output

The output file contains one line for each test cases, in which contains an integer indicating the maximum profit Dog is able to obtain (or the minimum expenditure to spend)

Sample Input

6 5
1
2
2
3
3
4
1 2
1 3
2 4
3 4
5 6

Sample Output

7





该题意就是求一个图中的最长路径,只是这里的路径为题目中的价值。而且·题目中的图不一定是联通的,也就是说,有可能有多个起点。所以在之前,先要新建一个节点作为起点,用来连接所有入度为0的节点。
又因为该题中给出的点的范围过大,用Dies或者SPFA会超时,所以这里有一个针对有向无环图的算法:DAG单源最短路。
先对图中的点进行拓扑排序,然后根据排序用DP进行最值的求取。
还有一点要注意的是:该图中给出的价值在节点上(权值),我们需要将其转化为在边上。将节点上的值该写到其入度的边上。

代码实现:
#include<iostream>
#include<stdio.h>
#include<string.h>
#define min 1<<30
using namespace std;
int first[100005];
struct node{
       int next;
       int w;
       int to;
};
int value[100005];                 //firstly ,every points' value
int val[100005];                   //update the every points' max value
node ver[2000005];                 //the ver
int flag[100005];                   //the number of every point's in ver
int visp[2000005];
int main(){
    int n,m;
    while(cin>>n>>m){                           //the number of points and vers
        memset(visp,0,sizeof(visp));
        memset(first,-1,sizeof(first));
        memset(ver,-1,sizeof(ver));
        memset(flag,0,sizeof(flag));
        for(int i=1;i<=n;i++){
             scanf("%d",&value[i]);
             val[i]=-min;
             }
        for(int i=1;i<=m;i++){
                int temp1,temp2;
                scanf("%d%d",&temp1,&temp2);
                if(first[temp1]==-1){
                      first[temp1]=i;  
                      }
                else{
                      int temp4=first[temp1];
                      first[temp1]=i;
                      ver[i].next=temp4;
                      }
                ver[i].w=value[temp2];
                ver[i].to=temp2; 
                flag[temp2]++;
                } 
        int times=m+1;
        for(int k=1;k<=n;k++){
                if(flag[k]==0){
                     if(first[n+1]==-1)
                            first[n+1]=times;
                     else{
                            int temp3=first[n+1];
                            first[n+1]=times;
                            ver[times].next=temp3;
                            }
                     ver[times].to=k;
                     ver[times].w=value[k];
                     times++;
                     flag[k]++;
                     }
                     }
        int a[100005];                                  //when finish, the array saves the points' topu sort
        int first1=0;
        int last=0;
        a[last++]=n+1;
        while(first1!=last){
           int temp=a[first1];
           first1++;
           for(int k=first[temp];k!=-1;k=ver[k].next){
                      if(visp[k]==0){
                            visp[k]=1;
                            flag[ver[k].to]--;
                            if(flag[ver[k].to]==0){
                                     a[last++]=ver[k].to;
                            }
                            }
                            }
                            }
        val[a[0]]=0;
        for(int g=0;g<first1;g++){
                for(int i=first[a[g]];i!=-1;i=ver[i].next){
                        if((val[a[g]]+ver[i].w)>val[ver[i].to]){
                                   val[ver[i].to]=val[a[g]]+ver[i].w;
                                   }
                                   }
                                   }
        int maxn=-min;
        for(int k=1;k<=n+1;k++){
                if(first[k]==-1){
                        if(maxn<val[k])
                               maxn=val[k];
                               }
                               }
        cout<<maxn<<endl;                   //from out ver is 0 to in ver is 0's points' maxn value
        }
    return 0;
}
        

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值