关闭

移植sqlite3.7.4到s3c2440(本人使用的是tq2440)

1289人阅读 评论(0) 收藏 举报

编译环境:

主机:Ubuntu10.10

交叉编译工具:4.3.3

开发板:tq2440

源码:sqlite-autoconf-3070400.tar.gz (下载于:http://www.sqlite.org/download.html


 1.解压数据库源文件并进入解压后的目录,如下:

 #tar - zxvf sqlite-autoconf-3070400.tar.gz
 #cd
sqlite-autoconf-3070400

2.配置

  #./configure --host=arm-linux --prefix=/opt/EmbedSky/apps/sqlite-autoconf-3070400/install3.7.4 --disable-tcl

  看提示,好像--disable-tcl 这句华没什么用了

 3.make

  #make

  这时候却出现错误:

这时候参考了网友博客(表示感谢!),需要:

修改Makefile中的 -DPACKAGE_STRING=/"sqlite 3.7.4/" 把sqlite和3.7.4中间的空格去掉

http://hi.baidu.com/%D6%DC%BB%AA%B1%F3/blog/item/57b8794cbf4b1906b2de0575.html/cmtid/006e96033f06160d728da5f0

 

修改后编译就没问题了,

#make

#make install

 

4.将/opt/EmbedSky/apps/sqlite-autoconf-3070400/install3.7.4 目录下的bin目录和lib目录下的内容分别复制到开发板的/bin目录和/lib目录下,就可以使用sqlite3了

在开发板上运行

# sqlite3
SQLite version 3.7.4
Enter ".help" for instructions
sqlite>

 

OK!表明移植成功!

 

 

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:23848次
    • 积分:368
    • 等级:
    • 排名:千里之外
    • 原创:11篇
    • 转载:3篇
    • 译文:0篇
    • 评论:13条
    文章分类
    最新评论